Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For working remotely, I recently bought a Logitech H390 so that I can communicate with my coworkers remotely from my WinXP machine using software integrated with our company's phone system. Unfortunately my coworkers consistently complain of hearing an echo of their voice. After some experimentation, it turns out that muting the mic on the headset removes this echo, so its pretty clear that my headset's mic is picking up their voice and sending it back to them.

Someone suggested I search for other mics that might be on my system, maybe built-in to my laptop. I found one potential mic and disabled it in the device manager. This has had no effect.

I've tried modulating the gain on the mic, lowering it and this has a very small effect. Lowering the headset volume has a pretty big effect. Unfortunately when I'm participating in meetings and everyone's sitting around a speaker phone I need to up the volume to strain to hear what everyone is saying around the conference table.

I've looked on logitech's website to see if I'm missing any special drivers/software that I should be using. There are no downloads listed when I lookup my headset.

So I appear to be in a conundrum, I can raise the volume so I can hear but produce an echo, or I can lower the volume and not hear.

Is there any way I can cancel the echo from my headset's mic more effectively while being able to have the volume at a comfortable level? Should my softphone software be doing a better job at echo cancellation? Or is it my headset that stinks?

share|improve this question

Since its for work its worth trying( buying?) a different mic . Better yet call a friend using the same mic with google voice . If the same echo occurs while using google voice then its the mic . If not your mic might just be incompatible with your companies software .

share|improve this answer
sadly this mic doesn't work with google voice on XP. Using google voice on my personal PC (Win 7) works like a charm. – Doug T. Jul 25 '12 at 13:56
So the same mic works ok on a different computer ... Can you use your Win7 PC to test with and call your job with ( it really depends on your company if you can do this .) . What I think is going on is that XP isn't compatible with your mic ( if its a USB mic then thats very likely . Push come to shove ask your boss if you can upgrade to Win7 , – Keithsoulasa Jul 25 '12 at 13:59
Not really, the XP is a work laptop connected through a VPN. My PC can't connect up to the VPN to get onto the phone server. – Doug T. Jul 25 '12 at 14:03
Is it a USB mic( does it connect with a flat USB cable ) or is it an analog mic( connects with 2 audio cords, green for sound , and pink/red for record) . – Keithsoulasa Jul 25 '12 at 14:05
Yep, that seems to be it, and the Logictech site doesn't appear to have a link for any drivers for it ( they must assume everyone's upgraded to Vista/Win7 .) Try to find a old school analog mic and try that . Good luck ! – Keithsoulasa Jul 25 '12 at 14:08

i found the default mic volume at 100 and echo was like the grand canyon one....i reduced the mic volume to 35, and it was the best for others to hear VIOP and almost nil echo

share|improve this answer

Sounds like the mic's too sensitive and there's mechanical coupling between its boom and the headset speakers because there's no sound damping built into the materials.

share|improve this answer

Here's what FINALLY worked for me:

in Devices and Drives

  1. Set logitech headset as the default and
  2. actually DISABLE the standard/realtek speakers.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.