Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home WiFi network with several machines running Ubuntu and Windows. lets say I want to SSH from one machine to the other -- how can I connect from one machine to the other on my home network?

If I go to one machine and type in ifconfig and gets its local IP (say 192.168.1.135) and and go to another machine and try to ping the IP (say "ping 192.168.1.135"), I get the error message "Destination Host Unreachable".

1) Is there some setting on my router that prevents one computer from pinging another? If so what would it be?

2) Connecting using IP addresses seems very fragile -- is there a way I can connect between computers using the computer names?

Updated:

Here is the ifconfig of one machine (lets say the machine I want to connect to)

eth0      Link encap:Ethernet  HWaddr 1c:xx
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:17728993633567635 errors:106373961801405810 dropped:35457987267135270 overruns:17728993633567635 frame:88644968167838175
          TX packets:17728993633567635 errors:70915991714139720 dropped:0 overruns:17728997928534930 carrier:35457995857069860
          collisions:88644989642674650 txqueuelen:1000 
          RX bytes:17728993633567635 (17.7 PB)  TX bytes:17728997928534930 (17.7 PB)
          Interrupt:45 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:86517 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86517 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10151683 (10.1 MB)  TX bytes:10151683 (10.1 MB)

wlan0     Link encap:Ethernet  HWaddr 00:xx
          inet addr:192.168.1.133  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:c7ff:fee7:9ec6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2012116 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2360821 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1036380262 (1.0 GB)  TX bytes:2585366008 (2.5 GB)

And here is the other one: (lets say the machine I am connecting from)

eth0      Link encap:Ethernet  HWaddr f0:xx 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:44 Base address:0x2000 

eth2      Link encap:Ethernet  HWaddr f0:xx
          inet addr:192.168.1.136  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::f27b:cbff:fe25:19d8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1864 errors:575 dropped:0 overruns:0 frame:347391
          TX packets:2559 errors:19 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:476410 (476.4 KB)  TX bytes:386778 (386.7 KB)
          Interrupt:17 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:788 (788.0 B)  TX bytes:788 (788.0 B)

The router is a Cisco M20 (Firmware Version: v1.0.01)

share|improve this question
    
Could you post the ifconfig and ipconfig (Windows) of each machine? –  Tanner Jul 26 '12 at 0:48
    
The router can isolate the computers on the network. Firewalls can also block all incoming traffic. What is the model # of the router? –  wbeard52 Jul 26 '12 at 0:49
    
I understand that routers can isolate computers, but I cant seem to find anything in the settings of my router that seems to say this. Is there a standard place one would look? –  Fasterz Jul 26 '12 at 1:25
    
@r.tanner.f I have updated the ifconfig info. –  Fasterz Jul 26 '12 at 1:31
    
I can't see anything with the configs... Can anyone else? Maybe AP isolation is turned on? Updated answer with how to check. –  Tanner Jul 26 '12 at 1:40

1 Answer 1

up vote 1 down vote accepted

"Destination Host Unreachable" seems to indicate that there is a network problem here. If your computer could find the other computer, it would most likely timeout at least. The only thing that should prevent your computer from pinging another is a firewall blocking the ICMP protocol. Many machines do block this by default, but again that should result in timeout error versus "Destination Host Unreachable."

Make sure AP isolation isn't turned on. This is under Wireless, Advance Wireless Settings. This will separate your wireless network from the wired network. enter image description here

Connecting by names (whether through DNS or NBT) will still resolve to an IP address, but that's not to say it won't eliminate the fragility that you perceive. Unless you are setting static IP addresses on your machines they may occasionally change addresses when they periodically update with your router's DHCP service.

If you wanted to make a more robust environment, you could configure a DNS server which would dynamically update the IP addresses of your machines as they change, but this is way overkill for a small home network. You're probably better off sticking with IP addresses unless you're trying to accomplish a more specific goal.

share|improve this answer
    
Even though I have had not explicitely set up a DNS, on my older router when one does a gethostbyaddr() I have noticed that it often resolves the hostname to something like machinename.local. How does this happen? And can I not just use such names instead of the IP address? (Note: one this router newer router I am not able to look up hostname also, so this question is moot.) –  Fasterz Jul 26 '12 at 1:28
    
I've never seen that on a home router. That's actually pretty awesome. The router must have been acting as a DNS server (maybe somebody else can clarify/correct?) You could use names instead of IP addresses with a router like this, but that router was simply keeping record of the IP addresses of your machines and associating them with names. When you called for the name, the router was returning the answer in the form of an IP address. –  Tanner Jul 26 '12 at 1:31
    
That what I would guess as well. –  Fasterz Jul 26 '12 at 1:39
    
Just checked -- AP Isolation is disabled. –  Fasterz Jul 26 '12 at 1:41
    
I am marking your answer as correct. I got this working by enabling AP isolation, letting the router reconfigure itself, and then disabling AP isolation again. (Also I do have machinename.local working with the Cisco M20 as well, so now I can indeed "ssh machinename.local" on my home network.) Thanks very much. –  Fasterz Jul 26 '12 at 2:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.