Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Well, pretty much my question is the title. I use Google Chrome, Chromium, Firefox, and Internet Explorer 8 and was wondering how I could disable the automatic cursor placement when accessing different websites. I'm still a bit faster than all the browsers when typing in my usernames and passwords (which is really the reason why I'm asking) and it never fails that

I'll see my username enter in fine, then a couple of characters from my password, then my cursor will jump back up to the username field and plug in half of my password there and fail to login of course after I hit the enter key. Mind you, I'm usually typing in the user/pass and hitting enter afterwards fairly quick, so its not like I'm meaning to do this.

Also, it would help whenever I open up my home page (which is google) and want to type in a new url. Even google has it where the cursor will automatically jump to the search box after a few seconds, so I'll end up searching google for half of the url I was trying to type in the address bar.

I searched on google and here for a solution already, but didn't see an apparent one in the first couple of pages, so any help is appreciated.

Thanks,

Justin

share|improve this question

4 Answers 4

up vote 7 down vote accepted

Here is the solution for Firefox:

  1. Type the following into the Firefox address bar: about:config

  2. Right-click on any value and select New > String

  3. You will first be prompted for the preference name. Enter the following: capability.policy.default.HTMLInputElement.focus

  4. Next, you will be prompted for the preference value. Enter the following: noAccess

That's it!

If you're not happy with the change, undoing it is a little more complicated:

  1. Close Firefox if it's open by going into the File menu and choosing Exit.

  2. Locate your Application Data folder. The easiest way to do this is to go to the Start menu, choose Run, and type in "%APPDATA%" (without the quotes.)

  3. Navigate to your profile folder. It should be in Mozilla/Firefox/Profiles/_____.default, where the underscore is a string of random characters. Find the file called prefs.js and open it in a text editor, such as Notepad. (Do not just double-click it. You should be able to right-click it and choose Edit from the context menu.)

  4. Search for the line that contains capability.policy.default.HTMLInputElement.focus. It will look like this in its entirety: user_pref("capability.policy.default.HTMLInputElement.focus", "noAccess");

  5. Delete this line, and only this line. Save the file. You may now restart Firefox.

share|improve this answer
    
+1 for nice clear instructions. instructions for undoing it are even better. nice post! –  quack quixote Oct 7 '09 at 23:55

When the page is loaded, or even half-loaded, and you're ready to go, hit Esc or stop the browser from loading the rest of the page.

The behaviour you're seeing when you type in one input and then it jumps to another is because the JavaScript has finished loading and carrying out it's little focus script.

The JavaScript loaded with the pages is setting the focus on an element and often disregards how much you've typed, or if you've typed at all, before defaulting to the input field of choice.

share|improve this answer
    
Thanks for the response. I didn't realize that it was the javascript in the page that was causing this since it happens on so many different sites that I visit regularly. Is there a way to disable this element focusing in my JRE or specifically in each web browser? Thanks again, Justin –  Justin Bowers Sep 23 '09 at 2:33
    
Not really. Not unless you disable JavaScript entirely. But then it would probably break most of the site if you do. –  random Sep 23 '09 at 2:41
3  
JRE ?? Javascript IS NOT Java –  Michael B. Sep 23 '09 at 4:37
    
I wonder what else will stop working when stopping JavaScript. There's a lot of sites out there that depend on jQuery and the like to layout the content, or on Ajax to dynamically load data. –  Arjan Sep 23 '09 at 6:53
    
Sometimes you have to grin and bear the autofocus on a field if you want a site to play nicely and all whiz bangy. –  random Sep 23 '09 at 7:05

As you even encounter this "after a few seconds" at the very light page of google.com (today 13.44 KB in total, 3 KB when cache is used), I'd search for a way to make the pages load faster. The Google home page should be on your screen instantly.

I assume you did not disable caching? Do you have a lot of add-ons installed? Maybe some hyperactive virus scanner? Or some malware that needs time to spy on you?

If it's the internet connection: maybe your provider has some caching proxy server for you?

Or, if the computer is slow: disable Google Analytics and other tracking scripts by installing Adblock Plus.

(Just to avoid your password is shown in the username field: use a password manager rather than typing the credentials yourself.)

share|improve this answer
    
Google's autofocus has slowed down a lot since they introduced the suggestions. I blocked clients1.google.com and it's a lot faster for me now (though I can't promise that won't break any other apps). –  bobince Sep 23 '09 at 10:55
    
To disable Google Suggest see googlesystem.blogspot.com/2008/08/… –  Arjan Sep 23 '09 at 11:14

For Firefox,install the Greasemonkey addon then the user script called "Unfocuser". Worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.