Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using the following ~/.fonts.conf to encourage font smoothing, particularly in GTK apps like firefox:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintfull</const>
  </edit>
 </match>
 <dir>~/.fonts</dir>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
 <edit name="autohint" mode="assign">
 <bool>true</bool>
 </edit>
 <edit name="hinting" mode="assign">
 <bool>true</bool>
 </edit>
 <edit mode="assign" name="hintstyle">
 <const>hintslight</const>
 </edit>
 </match> 
</fontconfig>

This works well for most proportional and monospaced fonts, but some, such as poor old Courier New, end up washed out.

Is there a way to disable hinting for single fonts in ~/.fonts.conf?

share|improve this question
add comment

1 Answer

I would try with the following:

 <match target="pattern" name="family" >
    <test name="family" qual="any">
      <string>Courier New</string>
    </test>
    <edit name="autohint" mode="assign">
      <bool>false</bool>
    </edit>
 </match>

Change the specific edit to what you need, e.g. hintstyle, etc.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.