Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm Trying to connect to internet. I have Virtual Box and Debian in it.

I'm not able to do it.

When I try ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
...

Thought in /etc/network/interface I have

auto lo 
iface lo inet loopface

allow-hotplug eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static
address 192.168.1.18
netmask 255.255.255.0

To etc/init.d/networking restart

siocsifaddr no such device 
eth1:  ERROR while getting interface flags: No such device
SIOCSIFNETMASK: no such device 
eth1:  ERROR while getting interface flags: No such device

ifconfig -s prints

iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR FLG
lo       16436 0    696      0       0 0        696       0   0       0    L

Can somebody help me please. Thank you in advance

share|improve this question
    
What does ifconfig -s output? –  Marco Jul 26 '12 at 13:10
    
That's all? No network devices are listed at all? At least the loopback device lo should be mentioned, otherwise there is something seriously wrong with your setup. –  Marco Jul 26 '12 at 13:29
    
The kernel seems not to detect your network hardware. Do you find the device in the output of lspci or lsusb? Does dmesg|grep eth output something related? –  Marco Jul 26 '12 at 13:58
    
@Macro Thank you very much, I solved my problem. :) –  Maria Jul 28 '12 at 5:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.