Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a somewhat twisted network setup, mainly because I have to share the wifi signal coming from the next door (long story). Recently, I wanted to add NAS and other things that required Ethernet connection, so I bought a Netgear wifi extender (WN2000RPT) that not only extends the wifi network but also provides four Ethernet ports. I then connected ReadyNAS to it.

It worked fine, except for one quirk. I cannot resolve the local hostname of my NAS, mothership.local, when I am on the extended wifi SSID. It works fine when I am on the original SSID. Once I resolve it once, I think I can go back to the extended network to use the NAS, which works faster (I'm thinking the transfer is handled by the extender and does not travel all the way back to the DSL modem that provides the original network).

It would be much simpler if I can resolve the local hostname while on the extended network. Is this an inherent limitation of the extender I'm using (i.e. it does not broadcast Bonjour calls)? Or is there an workaround?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

bonjour works via multicast. Some extenders don't support multicast forwarding. Check if your extender supports multicast or if it can be enabled.

share|improve this answer
add comment

Well instead of relying on a DNS resolution you can hardcode it in /etc/hosts (in Windows, it's C:\Windows\system32\drivers\etc or %systemroot%/system32/drivers/etc/hosts).

This will speed up things a bit but I don't think you will notice the change. It should however works as a temporary solution for not resolving the hostname.

DNS protocol works on port 53 in UDP - check if this traffic is not blocked and if the extender has a correct DNS address setup. It should be default gateway if I'm not mistaken.

share|improve this answer
    
Thanks. The trouble is that the DSL model uses DHCP, so I don't really want to hardcode the IP. I will check the UDP port; I think the extender has the correct DNS server (the main gateway, that is). –  ntrolls Jul 26 '12 at 13:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.