Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Qwest Aciontec Q1000 modem/router combo, which does not support loopback. I run a webserver on the LAN, and when I'm on the LAN, I can only access it by its local IP 192.168.0.201. When I'm outside the LAN, I can access the machine by typing mm.example.com. I can do this because I have a no-ip account that points to my WAN IP, and I have port forwarding set up.

When I'm on my laptop, I have to edit my /etc/hosts file such that mm.example.com points to 192.168.0.201. Then, when I leave the WAN, I have to comment that out.

Can I just purchase a router that supports loopback so that I can access my webserver on the LAn by visiting mm.example.com or do I need to purchase a new modem as well?

share|improve this question
    
What are you precisely changing in the hosts file? –  kinokijuf Jul 26 '12 at 15:27
    
Can you describe what exactly you are trying to do? The question is not clear as to what you mean by "loopback" in this context. Are you referring to NAT Reflection? –  MaQleod Jul 26 '12 at 16:25
    
I run a server on my local network. On the LAN, I can access it at 192.168.0.201. I have port forwarding set up so when I'm outside the LAN, I can access it at mm.example.com. If I'm on the LAN with the server, I can't access it at mm.example.com because my router doesn't support loopback. Consequently, I have to edit my hosts file to direct mm.example.com to 192.168.0.201 and when I'm outside the LAN, I have to comment that out. –  jessh Jul 26 '12 at 18:21
    
Please edit your question to include the expanded explanation provided in your comment. –  Daniel Beck Jul 26 '12 at 18:57
1  
It sounds like you have misconfigured your webserver and/or the access in your router. –  Synetech Jul 26 '12 at 19:03

3 Answers 3

up vote 2 down vote accepted

If you switch your Q1000 to be just a modem, then you can use a router that supports loopback NAT and that should solve your problem. To do this, go to Advanced IP Configuration and check RFC 1483 Transparent Bridging. Note that you will need to configure the new router to perform whatever authentication and handshaking your ISP requires, such as PPPoE or PPPoA. (Typically, nothing is required.)

The directions for the Actiontec Q1000 specifically can be found here: http://foxsys.blogspot.com/2011/10/qwest-actiontec-q1000-in-rfc-1483.html

share|improve this answer

So the feature you want is not on all routers, but it is needed for anything that is using NAT. If your modem is bridged, you do not need to worry about this feature. If your modem is in routed mode and you have a double-NAT situation, then you have a far more complex setup than is necessary (only use one device to NAT, but make sure it is one that can do NAT reflection/loopback).

share|improve this answer

Give this a try, works really well for me.

http://www.mobilenetswitch.com/

Configure IP Addressing, Wi-Fi settings, Proxy Server, Drive Mappings, Default Printer, Dynamic outgoing (SMTP) mail server, Time Zone and much more for each location you use your machine.


it dynamically switches the hosts file too. ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.