Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop and a desktop PC, both running Windows Home Premium. Mozilla Firefox is the default browser.

The thing is, the anti-aliasing / font-smoothing in Firefox is pretty good on my desktop PC, and kinda rough in the Firefox on my laptop.

Website I tested:


Click on the image to enlarge

Screenshot 1


Screenshot 2

Notice the difference? I use the same addons on both Firefoxes. Any idea what could be causing the font-smoothing difference?

More Info:

Use hardware acceleration when available — option is checked in both browsers.

Adjust ClearType text — settings checked. Both have the same.

✔ Both systems have the font (Open Sans) installed locally. Same quality ttf files.

share|improve this question
Do you found a solution? I have the same problem but nothing works. – Scoutman Jan 27 '13 at 22:01
@Scoutman No, I haven't found any solution either. – its_me Jan 28 '13 at 9:27

In about:config, check the settings for gfx.font_rendering.cleartype_params and compare them between your desktop and laptop.

Source: DirectWrite Text Rendering in Firefox 6


These are effectively local overrides of ClearType registry settings that are set by running the ClearType tuner tool (Control Panels > Fonts > ClearType Text Settings).

I didn't get to test these configurations because I don't have Mozilla Firefox on Windows 7 at the moment, but judging from that article, it looks like this may be the answer you're looking for.

share|improve this answer
Again, they are just the same. :( – its_me Jul 26 '12 at 17:19

I found a solution that works on my computer.

In about:config set:

gfx.direct2d.force-enabled = true

More information are here:

share|improve this answer

Adjust your ClearType settings.

ClearType is a software technology developed by Microsoft that improves the readability of text on existing LCDs (Liquid Crystal Displays), such as laptop screens, Pocket PC screens and flat panel monitors. With ClearType font technology, the words on your computer screen look almost as sharp and clear as those printed on a piece of paper.

  1. In Windows Explorer, go to "Control Panel\Appearance and Personalization\Display".
  2. On the left sidebar, click "Adjust ClearType text".
  3. If you want to have the same ClearType output on both computers, you can compare the settings of both your Windows 7 computers.

enter image description here

share|improve this answer
Was just about to add that to my question. Done this already. Doesn't change anything. Thanks though. :) – its_me Jul 26 '12 at 16:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.