Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a microserver running Ubuntu from which I have created some Samba shared folders which I access from my PC and laptop running Windows 7. I have created some symlinks (using mklink /d) on the Windows machines that point to Samba shares on the microserver. However, there seems to be something odd with the permissions within the symlinks.

If I access the shared Samba folders directly from within Windows I can create files or folders within them. But if I try to do the exact same thing within the symlinks my permissions are limited: all the folders in that share have a padlock Symbol on them in Windows Explorer, and when I right-click within those folders and click "New", the only option is "Folder" with an administrator-shield symbol next to it, rather than the normal file types I can create. I can go to the Security settings for any of folders within the symlink and give Modify permissions to "Everyone" which removes the padlock symbol and then allows me to right-click and create other file types, but I have to do this for every folder individually, and any new folders that are created get the padlock symbol and restricted file-type list.

This seems to be specific to the Samba shared folders: I don't get any permission limitations when creating symlinks to shared folders on another Windows box.

Any ideas?

share|improve this question
    
Same problem here (W7 folders symlinked to FreeNAS SMB share). Did you ever get a fix? – blackworx Jul 10 at 13:22

You must log in to answer this question.

Browse other questions tagged .