Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I powered off my Revo this afternoon to change the power strip, plugged in a second USB hard drive and booted it up, only to find the machine won't POST. It's been running happily as an HTPC for at least 9 months and has been rebooting fine. I've tried all the usual approaches - removed all external devices, BIOS reset jumper, moved the RAM around/used only one stick, even removed the Wifi card, and I still get nothing on the screen either by VGA or HDMI. The fan spins up to 100% and stays there on power-on. Googling reveals no other person with this problem, can anyone help? It's a Revo R3600 (Atom 230 HT), made in 2009, with 2GB RAM and original ION chipset.

Edit: Tested the PSU and it shows 17-18V (can't get a clear reading, but looks about right, says 19V on the unit), tried different RAM and removed the hard drive, no joy. Also checked for any suspicious burnt electronics and can't find any. Would really like to resurrect this machine as it's the house media centre and server.

share|improve this question
    
Sounds like the motherboard might have just given up the ghost. Your troubleshooting steps sound very extensive and everything I was thinking of writing to help you is already covered by your post. Unfortunately I think you might just have irreparably damaged hardware. Sometimes things just go sour for no reason other than sustained operation, although it might've been a power surge or static electricity or excessive humidity or heat, too... hard to say. Either way I don't think you're going to get a ton of help here about how to magically fix a totally bricked HTPC. Sorry bud. :( –  allquixotic Jul 27 '12 at 1:13
    
@allquixotic Yeah, I guess you're right. I was just clinging to hope that there might be some miracle cure for the device; it's only three years old, it shouldn't have failed already. Unfortunately there's no warranty and I can't justify the expense of replacing it yet. To anyone else finding this topic, it means your Revo is most likely dead :( –  Gargravarr Jul 28 '12 at 1:58
    
Did you find a solution in the end? I have R3700 and the same exact problem. Tried everything same as you. –  opengrid Feb 21 at 17:22
    
@opengrid Sorry, looks like complete hardware failure. Shame cos these are nice devices, but I had to throw the machine away. Good luck finding a replacement! –  Gargravarr Feb 22 at 18:43
    
@Gargravarr in my case it was diagnosed that gpu was overheated over time since it was used as a media center and had to display content on a large TV screen with high resolution. The only way is to replace the mainboard but it costs too much. I decided to buy Chromecast for $35 instead. –  opengrid Mar 15 at 14:44

1 Answer 1

this happened to me twice on different ocassions. dont know which solved the problem but heres what i did

played with the jumper for the bios. removed the exhaust fan and cleaned it out. removed the heat sink and re applied thermal grease. removed the 2 memory sodimms, and ran something metal on the contacts on my memory sticks to lightly scrape the contact points of the memory sticks as well as the connector of the memory bank on the motherboard.

let it rest for a day.

the following day, my acer revo 3600 booted up.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.