Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Firefox 13.0 on Ubuntu 11.10.

When accessing the following web page, with Javascript enabled, the "home" and "end" keys will not scroll to the start/end of the document (ctrl-home / ctrl-end work).

The page does not use frames. It does use a lot of CSS, including a scrolling sidebar.

Is there a CSS tweak I could use to fix this? I'm using "Stylish" to override a few other annoyances and could add in a fix if possible.

Why is FF behaving like this?

Edit: I did check to see if I'd activated caret browsing. The behavior noted occurs with caret browsing off.

share|improve this question
FF beta (14.0.1) on windows and it working fine here. – Rob Jul 26 '12 at 19:07

Sounds like you accidentally activated Caret Browsing by pressing F7. Try pressing F7 again to deactivate caret browsing. If that is the solution, you may want to turn on the warning that you're entering Caret Browsing mode again by going to about:config and looking for the following preference:


Set its value to true. This way Firefox will prompt you for permission the next time you press F7.

share|improve this answer
Nope. I checked for this though. – Dr. Edward Morbius Jul 26 '12 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .