Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with my Chrome browser, where it does not go the background, if you were to click on a separate window that is then supposed to come to the foreground.

With any other applications, this foreground/background business works just fine, so I know its not an OS issue. What can possibly be the cause/fix for this?

I am using Chrome version: "20.0.1132.57 m" (lastest) and my OS is Windows 7.

P.S. I am also having a hard time googling the issue, as it is not clear to me how best to describe the problem to google.


share|improve this question
The only topmost/always-on-top extension that I can find is this one, so unless you were using that, then something else was going on. I don’t suppose it’s still happening is it? – Synetech Dec 7 '13 at 20:46
@Synetech Sorry for the delay in replying to you. Yes, I resolved the problem a while back, but without re-installing. To be honest I do not remember what it was, although I vaguely remember it being related to some program Win-7 was automatically running that I removed. – Manchine Dec 11 '13 at 15:43

The first thing I would do is uninstall chrome, and then reinstall. Have you tried doing this?

share|improve this answer
Yeah, I have already tried, but no dice. – Manchine Jul 26 '12 at 19:16

Have you checked your add-ons and maybe tried deactivating the them one by one?

Also, you can start the Chrome Task Manager and then right click the title bar and see if you got the 'Always on top'-feature selected there.

share|improve this answer
Hmm, I didnt think the add-ons would matter, but I will try it. – Manchine Jul 26 '12 at 23:53
That option only affects the Chrome Task Manager, not regular browser windows. – Synetech Dec 7 '13 at 20:27

Go to Settings → Advanced Settings and click [Reset browser settings]; then re-enable your extensions and put all other settings back to where they were.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.