Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

USB\VID_8087&PID_0020&REV_0000 <- Windows 7 x64 keeps nagging me that it can't install thedriver for this, nor can Driver Genius Professional, wasted money.

Since a few days i cannot use my SD Card adapter and my build-in camera isn't detected also. I disasemlbed the laptop, disconnected everything (camera, sd, mouse etc etc) and only left the stuff that needed to be connected to turn the laptop on (so I even removed the DVD drive).

Now, when I launched windows, It still nagged about the unidentifies devicE@! So it's a software problem? when disasembled and powered on at once, I put the camera plug back in and clicked detect hardware changes - no changes detected, the same with the SD Card adapter.

I know that VID 8087 is Intel but I can't seem to find drivers for 'PID 20'. Yet unknown device identifier thinks that that unknown device is my ethernet adapter - which is not because it works good! (and I only have one).

I have a Acer Aspire 5742G, nothing has been replaced, just stock parts. I keep it always clean and don't do anything that could hurt the laptop (except one time I created a scratch on the screen, which I fixed).

so, does any1 have a driver for that or can any1 tell me how to fix that issue? Everything worked great last week! (I barely use the camera and SD card, maybe once a month)

The laptop has been bought in april 2011 so it isn't that old (and produced in 2010).

Also does anyone recomend me a mini windows which I can install on a small partition and dual boot? Mini Windows 7 or something so I can check if it's not my windows issue?

BTW Maybe it's the camera? The driver installation says it can't find the cam!

after some googling I found this:

    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub

because of the missing driver (probly chipset because It's build in, - how Do I know that - I disasembled the laptop as I said... and disconnected as much as possible) the camera and SD cards won't connect? Normal USB ports work!

share|improve this question
1  
Just curious but have you tried reinstalling the chipset drivers? –  Phillip R. Jul 26 '12 at 20:44
    
Static electricity. Zap! –  surfasb Jul 26 '12 at 21:05
    
I did try reinstalling, but after reboot it's still unidentified, and the problem occured before disasembly, i wore required gloves and the laptop was out of its power sources. –  user144773 Jul 27 '12 at 3:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.