Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on an unfamiliar machine and I am trying to get a program called bib2x to work. Unfortunately, when I run the program, I keep getting a segmentation fault. My (limited) experience and research leads me to believe that this was a result of some kind of memory error, but I'm not sure how to proceed or how to fix the problem.

I've run the program accessing files that the user account definitely has permission to access. Any ideas on how I ought proceed?

Sorry if this is vague. It's a vague problem and I'm confused about what to do next.

share|improve this question

migrated from stackoverflow.com Jul 27 '12 at 0:47

This question came from our site for professional and enthusiast programmers.

    
To better understand what the problem is, you can run: strace <command>. If you're lucky, the output from strace will provide you with more information on how to correct your problem (assuming that this is not a real bug with bib2x). –  pmohandas Jul 26 '12 at 2:48
1  
You should work on your accept rate. –  Daenyth Jul 26 '12 at 3:06
    
I would consider almost any segfault "a real bug". Exceptions are rare. –  jordanm Jul 26 '12 at 3:17
    
But it could be helpful for discovering a workaround. –  tripleee Jul 26 '12 at 6:56
add comment

1 Answer

Does the program run at all (e.g., can you run something like

bib2x -V

and report the version)?

It's going to be a bit difficult to debug that problem on an unfamiliar machine, without the bib2x source and a way to recompile it. You could try reinstalling it (it looks like executables are available for several platforms here), or recompiling it if that's an option.

Can you temporarily just use the online bib2x converter?

share|improve this answer
    
It appears to be GPLv2, so the source should be available. –  jordanm Jul 26 '12 at 2:40
    
Yeah, it does report the version. I tried compiling the script and at make it outputs an error: (atomdatabinary.cxx:117:39: error: 'memcpy' was not declared in this scope make[1]: *** [atomdatabinary.lo] Error 1 make[1]: Leaving directory /home/alex/bib2x-0.9.0/src' make: *** [install-recursive] Error 1 I'm guessing this won't be an easy error and I should look for an alternative solution? I can post the whole output if it would be helpful. –  Alex Jul 26 '12 at 4:53
    
Can you post some details about how you're using bib2x? What version is it? What usage causes the segfault? What platform are you running on? –  Keith Flower Jul 26 '12 at 5:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.