Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm puzzled: today I have tried to to connect to to my Mac at the office. To do so I use my company's active directory user account (this account has admin permissions on the Mac). The connection has been refused.

So I connected using my local admin account and succeeded.

Now a few things are puzzling me:

  • My network user account is not showing up in the list of users ion the Sys Prefs. Is it supposed to be there or are network account never showing up there?
  • If I login using SSH, Mac OS claims that my network account no longer has SUDO permissions.
  • Looking at the disk shows me a folder under "Users" that belongs to my network user ("rene") but I cannot access it with the local admin account.
  • If try to switch to the network account while connected via ARD, the connection is closed. Afterwards I cannot reconnect until I reboot the Mac.

The Mac is running Lion.

Main issue is: the network user has files on disk that are extremely important. How can I get to these files? And what the hell happened to my network account? How can I get it back?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

To access your files, select your rene user folder and press Command I. Go to the permissions and sharing section, click on the little lock icon, enter your password, and add your logged-in user as having full read and write access. Then, click on the little gear icon underneath that and click Apply Recursively (or something like that). You should now have full access to all of that user's files.

However, if for some reason that doesn't work. you may want to enable the root account. To do this, open Terminal and type dsenableroot. It will ask you for your current user's password and then for a new root password twice. (When you type, you will not see any password characters or anything.) You will then be able to log in as root or System Administrator on your local computer. Once you've done that, you can follow the procedure I listed above.

As for your other questions:

  • No, network users are not listed under the list of users--with one exception. Once you have logged in and created a local version of your network account, the account will show up in the list.
  • It sounds to me like there is a problem on the network side. I would go to your network sysadmin and talk to him/her about your (computer) problems, and they will probably be able to resolve the issue.

Once you've recovered all the files you want from the rene folder, remember to go to Disk Utility and run Permission Repair to restore the directory to the default permissions. You can always edit the permissions again later.

share|improve this answer
    
Getting access vie CMD+I worked. And I also reached somebody at the office who switched the iMac off and back on (really just press the button on the backside twice) and then I could login again. Before the whole Mac died when trying to login. Very weird. –  Krumelur Jul 27 '12 at 9:34

It's also important to know that a long-standing limitation exists in OS X 's VNC server that prevents network-based accounts from authenticating a VNC session; a local admininstrative account must be used. In the future it may be useful to create an account like "rene.vnc" with the same password as your standard account and use that for VNC connections in the future.

share|improve this answer
    
Not true. Until that issue I was able to connect with VNC and my network account. Even now it is working again. –  Krumelur Jul 31 '12 at 17:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.