Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a Y-cam Black CCTV camera that is connected to our network. It was initially connected by a LAN cable for the setup, and once that was done we left it to use the wireless connection. When using a cable, we can access the web interface fine, but when connected to wireless we can't get to it. The web address we use is http://192.168.6.100:8000. This IP configuration is set up on the router side - the camera uses DHCP (though it does specify it's own port).

At first I thought the wireless wasn't working, but when we tested the alarm/movement sensor, email and FTP upload functionality while connected to wireless it worked perfectly. We have DDNS set up on our router, and accessing http://oururl.dyndns.org:8000/ in a web browser shows the control panel fine. Also, using the iPhone app or simply using telnet to access it works just fine. However, explicitly using the IP address it doesn't work.

C:\Users\leonardc>telnet 192.168.6.100 8000
Connecting To 192.168.6.100...Could not open connection to the host, on port 8000: Connect failed

I'm unsure why this would happen - I can't see it being a firewall problem (all outbound from my PC is allowed - the default Windows setup). I'm fairly sure it's the router though - we have just put it in. Before we had a Netgear DG834G - we have replaced it for a Netgear DGND3700v2.

Edit:

Here is a screenshot of the attached devices screen on my router, showing it is using 192.168.6.100

Attached Devices

Here is a screen shot of the CCTV status page, showing it using 192.168.6.100

Network Configuration

UPnP is turned off on the router completely.

This is the inbound rule in the firewall config on the router:

Inbound firewall rule

Wireless isolation is turned off - so it can't be this either.

Further Edit:

I have changed the IP and Port to two completely new ones - restarted the router and the camera. Exactly the same problem aterwards: I can connect with the DynDNS address but not the local IP/Port combination. Running out of ideas here... Y-cam support are useless.

Unfortunately there is no logging on the camera and the logging on this router is pretty basic - there doesn't seem to be an option to increase it to a higher level unfortunately.

Any ideas?

share|improve this question
    
Have tried to ping it? Do you have that problem from other computers, too, or just this one? What have you configured on your router to forward the networktraffic to the cam? –  wullxz Jul 27 '12 at 12:58
    
Yes I've tried to ping it. This happens from any computer on the LAN. On the router I have a custom service (port 8000) and a firewall rule that uses it to make sure data is allowed through to 192.168.6.100 on port 8000. As I said, that works fine - even when accessing it internally (still using the dyndns url) –  Leonard Challis Jul 27 '12 at 13:52
    
And did it respond to your ping? Can you upload a screenshot of that forwarding rule on your router? –  wullxz Jul 27 '12 at 14:26
    
No, it didn't respond to ping (though I'm not sure if the CCTV is even supposed to respond to ping). Added screenshots, but I don't see how it's relevant as it's just an inbound rule - I am accessing it by IP on the specific port, and using the external address it works anyway. –  Leonard Challis Jul 27 '12 at 14:51
1  
My last thought is, that your router puts lan and wlan devices in different networks or at least prohibits wlan devices to communicate with other devices (I know that Fritz!Boxes have or had such a feature). Look out for something like that. –  wullxz Jul 27 '12 at 14:59
show 1 more comment

5 Answers

It's a bug in the firmware. Netgear have had a beta firmware (v12_t4) for months that fixes this issue, but strangely refuse to take it out of beta and publish it on their website.

I found a copy of the firmware by following the posted link on this forum...

http://forum1.netgear.com/showthread.php?t=77750&page=4

Clearly it's an issue with ARP resolution, and the beta firmware fixes that.

HTH.

Toby

share|improve this answer
    
In the office tomorrow - I will check it out and upvote/mark as answer accordingly - thank you! –  Leonard Challis Feb 6 '13 at 8:26
    
To prove it's the router, enable wireless isolation, save, and then disable it. Watch the problem go away temporarily. –  David Schwartz Feb 6 '13 at 8:36
add comment

In short, the IP changed. The wireless device shows to the router as a different interface than the wired networking, so the router created a new DHCP lease for it with a different IP address. If you can view the list of DHCP leases that the router has given out, you should be able to find what the new IP is fairly easily.

It's likely magically working due to the camera using UPnP to automatically forward the ports on the router to it's own IP.

share|improve this answer
    
Check my edit. The IP hasn't changed - it's 192.168.6.100. UPnP is switched off completely on the router. –  Leonard Challis Jul 27 '12 at 14:50
    
Also changed the IP and port and the same problem persists - see my latest updates –  Leonard Challis Jul 31 '12 at 8:25
add comment

Check if:

  • you're using a proxy that's not properly configured for local network
  • your desktop-firewall is blocking the traffic (disable it for testing purposes)
  • your router prohibits WLAN devices to communicate with other LAN devices
  • your actual used client devices is the only one that has problems reaching the cameras web interface
  • the ip address of your camera is still the right one
share|improve this answer
    
* No proxy * It's not - also disabled and no difference * Doubtful - can share files from a laptop connected via wifi * No, it's all * Yes, it's still the right one –  Leonard Challis Jul 27 '12 at 17:28
    
Is it possible to define accesslists in the camera? Maybe it's the camera blocking you. –  wullxz Jul 27 '12 at 17:39
    
No - and the camera hasn't changed - only the router has - but wireless isolation is switched off and everything is set up the same. Odd one! –  Leonard Challis Jul 30 '12 at 13:43
add comment

There is a fault with the dgnd3700v2 that isolates the wifi.

share|improve this answer
1  
Can you link me to anything that confirms this? –  Leonard Challis Aug 13 '12 at 13:00
1  
Or add more details to how this actually solves the problem? –  KronoS Aug 13 '12 at 18:25
add comment

Try a full reset of the router and make sure you have the current firmware .12 on the dgnd.

Hold reset until all lights blink. Keep holding rest and unplug wore cable wait 10 secs or so and plug power cable back while holding reset button down for about 20 secs.

Reconfigure router with the settings required by ISP and your devices.....

Hope that works...

Cheers Anthony

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.