Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed a fresh installation of XP SP3 on a hyper-v virtual machine. Nothing is installed besides Microsoft Security essentials.

If I try to install chrome with the alternate all users installer, I get this error:

Google update installation failed with error 0x80070057

I've tried a manual uninstall for chrome, cleaning the registry with ccleaner, running the installer as administrator, and starting from scratch by installing XP SP3 again.

Any ideas? I didn't encounter this issue a few months ago. Is there an older version of the alternative installer still available?

share|improve this question
    
I don't know if it helps, but take a look at this thread. –  amiregelz Jul 27 '12 at 21:59
    
Unfortunately, I doubt it's as simple as a permissions issue. I've tried installing as user with local admin privileged as well as the administrator user. –  Force Flow Jul 28 '12 at 5:48
add comment

2 Answers 2

If it is not a permissions problem, I would take a look at it with something like Process Monitor setting a filter for chrome, and when you get the error, see exactly what operation failed.

Then, if it is something like a specific access denied, or file not found, or something similar, you can do more specific troubleshooting/repairs.

share|improve this answer
    
There were a number of "name not found" statuses, but nothing with a failed or denied status. –  Force Flow Jul 30 '12 at 13:37
add comment
up vote 0 down vote accepted

I managed to sidestep the error by using the MSI installer.

https://www.google.com/intl/en/chrome/business/browser/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.