Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7 64 bit. I checked the radio button [Show hidden files, folder, and drives] in the Folder Options. I then log out and log back in and it has been reset to Don't show hidden files, folder, or drives. This is very annoying any help would be greatly appreciated.

Note: this happens to all the windows 7 machines in our office that i know of.

Update:

I have run mbam and it didn't find anything wrong.

I misspoke in the my comment I am a programmer in our IT dept which is why I want hidden files turned on.

I have local admin on my machine and can run regedit.

I do not have permissions to change the domain controller settings at all but my boss has told me if I find something promising he would make the changes.

Any help or suggestions will be greatly appreciated

share|improve this question
    
Are you on a domain? –  Tanner Jul 27 '12 at 20:55
    
@ r.tanner.f yes, I'm in the IT Dept but I'm not a programmer i won't have ready access to the domain controller –  claybo.the.invincible Jul 27 '12 at 21:00
    
.. or all of them are infected by a trojan. I don't remember the name, but we had similar problems due to some auto-run type of trojan –  stijn Jul 27 '12 at 21:01
    
Run MBAM to find out? If it's a virus then it's a whole different problem. –  Tanner Jul 27 '12 at 21:24
1  
Do you have any GPOs to set this option to on by default? That way every time you logged out and back in it would have reset. –  Joe Taylor Aug 1 '12 at 12:47

2 Answers 2

up vote 1 down vote accepted

As has been said in the comments this is caused by a GPO applied to the system.
To check this you would need to look at the machine that handles GP settings for your domain, usually the DC.
The setting you are looking for (Server 2008) is in:
User Configuration->Preferences->Control Panel Settings->Folder Options.
In that you can modify the settings for Folder options for Win Vista and later and XP machines seperately.

it's quite difficult to spot this setting as it doesn't seem to show up in RSOP on the machines I've checked but is showing up in GPResult.

Good luck getting your boss to spend the time looking for it. this is where good documentation / commenting comes in handy :-)

share|improve this answer

To keep user setting on exit create the key NoSaveSettings REG_DWORD with a value of 0

in

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

This setting apply to the current user account. For the default user and system add the same key/value there:

HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.