Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Fedora 17 auto login feature does not work through the GUI in KDE:

System Settings -> Login Screen -> Convenience -> Enable Auto Login.  

It accepts the changes, but when I reboot, I am still prompted to select a username and type a password. The GUI seems to be broken. Screenshot:

enter image description here

So if this GUI bit doesn't work, how can I enable autologin on fedora 17?

share|improve this question
add comment

4 Answers

For KDE, in /etc/kde/kdm/kdmrc set AutoLoginEnable and AutoLoginUser.

This works in a Fedora 16.

share|improve this answer
add comment

This particular setting requires root access to change. Try logging in as root and changing the setting.

share|improve this answer
    
The window prompts user for the root password when I choose the "apply" button. So it knows I need root access to make a change. I was never able to get it to work, but I found the work around described below by editing custom.conf. –  Eric Leschinski Jul 27 '12 at 23:01
add comment
up vote 1 down vote accepted

Adding "Automatic Login" feature in Fedora 17.

The automatic login feature will automatically login as a specific user each time you boot the computer. Use this feature only on a single user machine as it will not provide you with an option to login as another user.

Note: Fedora 13 does not automatically select Auto-Login. However, if manually selected at GDM automatic login will commence.

Note: GDM will not allow you to auto-login as root! You must choose a normal user for this feature.

Note: If you intend to use the Timed Login feature you cannot use Automatic Login. You must choose one or the other.

Here are the steps:

  1. Edit the following file: /etc/gdm/custom.conf

  2. Make a backup copy of the custom.conf as custom.conf.bak So you can rollback should something go wrong.

  3. You should see rows that look like this:

    [daemon]
    [security]
    [xdmcp]
    [greeter]
    [chooser]
    [debug]
    
  4. Enter the following lines under the [daemon] line, replace 'el' with your username you want to login with:

    [daemon]
    AutomaticLoginEnable=true
    AutomaticLogin=el
    
  5. Save and exit. Reboot your computer and should auto log in as your specified user.

Source: Custom GDM Configuration For Auto And Timed Login

share|improve this answer
add comment

You could just go to System Settings -> User Accounts -> Select your user and click Auto Login

share|improve this answer
1  
Have you tried it yourself? If you use KDE, that doesn't work. –  Eric Leschinski Nov 12 '12 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.