Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have disabled Windows Update on Windows 7, but it still downloads and installs critical updates. As with Windows XP, these updates occasionally create problems. But in XP, once I disabled automatic updates, the OS did not override my settings and continue to download and install critical updates.

After the most recent critical update to Windows 7, every time I boot up, the USB devices connected to a single port through 4-way hub don't install. I have to unplug the hub from the computer then plug it back in. Then the devices install.

I can use System Recovery to solve the immediate problem, but I'd like to disable automatic updates entirely.

Why does Windows 7 not respect my settings like Windows XP did?

share|improve this question
3  
@Rico: Disconnect your computer from the Internet. –  Mechanical snail Jul 28 '12 at 5:02
    
Critical updates are deliberately designed to fix only critical errors, and to make as few other changes as possible. Do not disable automatic installation of critical updates. It puts your machine at significant risk. –  SecurityMatt Aug 26 '12 at 12:07

3 Answers 3

After reading this, did you select "Check for Windows updates but let me choose whether to download them," or did you choose the box that said to download them but not install? If you did choose the latter, change it to just check for updates.

Keep in mind, though, that it is a terrible idea to disable Windows updates. You might want to look around on the Internet after installing said update (you failed to mention which, so I can't check for you), and see if there is a way to fix this problem.

share|improve this answer

We just disabled every automatic Windows Update and started to use WuInstall which is a command line tool for managing Windows Updates. It allows you to search for updates by there severity level ( /severity severity_level ), so you can filter the critical ones. I hope this helps

share|improve this answer
  1. Click Start > Run.
  2. Type services.msc and press Enter.
  3. Locate the Windows Update service and set startup type to Disabled or Manual depending on what you want. If the system won't let you do it, then Administrator privileges might be required.
  4. Make sure you know what you are doing and what the risks are.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.