Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Liferay version 6.1 and 6.0, when I start tomcat server its not starting , window close automatically. enter image description here

Please provide any hints or solutions for this issue.

share|improve this question
1  
I think you need to be running tomcat-7.0.27 –  user149205 Jul 30 '12 at 18:18

3 Answers 3

There was problem with java version 64bit, also have to instal JRE 64bit.

Details Once tomcat not started in Liferay I used Liferay IDE. Even in Eclips Juno(Liferay IDE) there was error "Failed to load the JNI shared library "C:/JDK/bin/client/jvm.dll" then found solution at this post on stackoverflow

share|improve this answer
    
It would be great if you could expand your answer a little, so future visitors can benefit from your solution as well. Which problem was there, exactly? Where does one get the JRE 64-bit and are there any special considerations needed while installing it? –  slhck Jul 30 '12 at 19:41
    
@slhck added details. –  Wasim Shaikh Jul 30 '12 at 22:33

I found the problem was fixed by seeing this post.

You can try these steps:

  • Go to environment variables.

  • Create "CATALINA_HOME" & set the path for tomcat folder.

Note: You should have better RAM configuration. Hope it helps.

share|improve this answer

Try to run catalina.bat run to see what's the error. Also checkout logs for any errors. Also remove the jre_1.6.0_20 from tomcat home and install a jvm of your own. This is a 32bit jvm which doesn't handle larger heap sizes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.