Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a new Dell inpiron. I need it for educational purposes and a wifi connection is really important.

Wifi is working properly in Windows7 but Ubuntu 12.04 is not even detecting the wifi card.

I even tried running via ndiswrapper but unfortunately that is also not working.

Any pointers in this regard will be highly appreciated.

share|improve this question
You need to wailt a little bit more: Bug #923809 “Upgrade bcmwl to verison (r300276) or gr...” – user148876 Jul 28 '12 at 18:11
On Fedora 17 also didn't work, Update solution for me too – Kumar Oct 3 '12 at 4:50
up vote 2 down vote accepted

I have the same chipset in my Dell Inspiron 5520. I use Fedora 17. After lot of internet research I compiled the following howto.

First, install development tools like gcc (yum install gcc) if not already installed. Then download the file from this link and do the following steps:

  1. sudo yum install dpkg

  2. mkdir BCM43142

  3. dpkg-deb -x Downloads/wireless-bcm43142-dkms- BCM43142

  4. cd BCM43142/usr/src/wireless-bcm43142-oneiric-dkms-

  5. sudo yum install kernel-devel kernel-headers

  6. vi wl_linux.c

  7. around line 46, remove the line #include <asm/system.h>

  8. save the file (:wq)

  9. cd ../../..

  10. make
    Things should work, and you'll have a file called "wl.ko" in the current directory.

  11. sudo yum remove broadcom-wl

  12. sudo mkdir -p /lib/modules/$(uname -r)/extra/wl

  13. sudo cp wl.ko /lib/modules/$(uname -r)/extra/wl

  14. sudo depmod -a

  15. sudo modprobe wl

This should work for Ubuntu as well, just change the package names where necessary.

Note: Wireless N is not supported in this driver version.

share|improve this answer
Thanks @Ahmad and Indrek, will check and post back (and close this question hopefully :) ) – Raghav Bali Oct 19 '12 at 13:13
It worked finally with little changes here and there : like using apt-get install instead of yum – Raghav Bali Feb 16 '13 at 18:54

Re-install the drivers:

sudo apt-get remove bcmwl-kernel-source

sudo apt-get install bcmwl-kernel-source

Hope it helps.

share|improve this answer
This isn't working – Raghav Bali Jul 29 '12 at 6:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.