Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Edit: Rewrote question to include updates and full current status.

I am attempting to connect a Windows XP (client) to a Windows 7 (Server) using tasklist. Currently, I have had no luck with this, tasklist gives the following error:

ERROR: Logon failure: unknown user name or bad password.

Command: tasklist /S PCName /U user /P password

The same error occurs when attempting to exchange user for any of the following:

workgroup\User, Workgroup\PC\User, PC\User

It is however finding the computer. If you attempt to connect using a computer that does not exist, the following error occurs instead:

ERROR: The RPC server is unavailable.

When attempting the same goal using PSList, as listed in comments below, the error is always the same:

The network path was not found. Failed to take process snapshot on Computer. Make sure that the Remote Registry service is running on the remote system, that you have firewall ports allow RPC access , and your account has read access the following key on the remote system: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Perflib

The following settings exist on the Windows 7 machine:

  • Discovery: On
  • File/Print Sharing: On
  • Turn on sharing so anyone with network access can read and write files in the Public folders.
  • Enable file sharing for devices that use 40- or 56-bit encryption.
  • Password Protected Sharing: Tried both on and off.
  • HomeGroup Connections: Tried both.

Additional information:

  • The Windows XP PC is able to access the Windows 7 machine via ping.
  • The Windows XP PC is able to access the Windows 7 public user folder.
  • An attempt to share another folder failed, Windows XP responded with: "...not accessible. You might not have permission to use this network resource..."
    • File permissions were set to full for 'Everyone.'
  • Link Layer Topology Discovery Responder is up-to-date on the XP machine.
  • I have the Remote Registry Service started and running.
  • I have enabled all RPC ports as well as even attempted disabling the firewall.
  • Works with safe-mode

Hopefully this helps give more insight into the problem.

share|improve this question
Why is the policy editor unavailable? Are you on a domain? – Tanner Faulkner Jul 29 '12 at 3:32
The policy editor does not ship with home versions. – Serodis Jul 29 '12 at 14:36
Your post makes it seem like the problem is logging into the windows 7/XP machines. Do you need help with those? Sounds like it should be the other way around. From your post, I'm not sure where the XP Home Premium fits in. – ZnArK Aug 1 '12 at 4:48
Sorry, Home Premium was meant to refer to Windows 7, since XP does not have a 'premium' version. – Serodis Aug 3 '12 at 3:23
Have you tried logging on using ComputerName\UserName? – Tanner Faulkner Aug 6 '12 at 18:53

I suggest first that you turn off all firewalls on the network and try tasklist again.

If tasklist still fails, it may be fixable even without the policy editor, by using registry editing to execute directly the same changes as would have been done by the policy editor, but this is risky and complicated.

Try using instead the free and equivalent PsList utility of Mark Russinovich.

If PsList will also fail, this will give us some additional information about the problem : Whether it is only the problem of tasklist or a general network access problem.

If nothing works, it would help to know if you can login via the network to the problematic computers by using the specified user-names and passwords.

share|improve this answer
Will check more into this comment tomorrow. – Serodis Aug 15 '12 at 0:47
After checking into this, the computer is unable to receive pings, it does show in the network list, but not accessible. Prior to having made some changes (The exact changes I do not remember) it was able to access public shares. Since, these have also disappeared. Current settings: Network discovery: On, File/Print Sharing: On, Public Folders: On, 40 or 56 bit encryption selected, Password protected sharing: Off. (Going to try turning this on tomorrow).Home Group connections: Attempted both methods. Tomorrow I will be trying both disabling the firewall and changing password protected sharing. – Serodis Aug 15 '12 at 22:21
"Cannot connect to remote registry on computer: The network path was not found. This message is displayed with the above settings and firewall disabled. I have attempted password protected sharing on and off and Remote Registry IS enabled and running. The network is accessible (fully) when using password protected sharing. XP will not access anything other than the public folder with passwords off, however. – Serodis Aug 17 '12 at 0:07
One must have passwords on the network or have problems with Windows. Also, XP needs the installation of Link Layer Topology Discovery to fully take part in Vista/7 network. See also this other answer of mine and verify against this Microsoft article. If nothing works, please detail clearly in your post the situation and your tests. For example, I have not understood whether ping now works or not. – harrymc Aug 17 '12 at 5:38
Will return with more on Monday. – Serodis Aug 18 '12 at 23:12

This site has some good info. Including a download link for tasklist as it appears that Windows XP Home edition does come with it included.

Windows XP Professional, Vista and 7 come with a powerful command-line tool called Tasklist that provides many details on the programs and processes that are running.

Many will be familiar with the graphical tool Task Manager, which I have discussed elsewhere, and which provides various kinds of information about the applications and processes that are running on a system. There are also several command-line tools that provide similar but even more detailed information. In this article I will discuss the features of the tool called Tasklist (the system file is tasklist.exe). This tool is part of the regular installation of the Professional version of XP but does not come with the Home edition. However, those with the Home version of XP can download Tasklist here. ...

share|improve this answer
I've went ahead and made some minor adjustments to the post, because I believe you are confusing the issue. First, Windows XP is not the problem machine, the machine I am unable to connect to is Windows 7. I only mentioned Windows XP to explain that its specific to Windows 7 and XP does work. Also, the missing component is the policy editor not tasklist. Windows Vista and Windows 7 Home Premium versions do not have a policy editor. – Serodis Aug 2 '12 at 23:45
@Serodis thanks for clearing that up – ZnArK Aug 13 '12 at 13:13

I had the same issue just recently while trying to do tasklist from a server '03 to a win7 pro machine. Turns out WMI (Windows Management Interface) needs to be allowed in windows firewall for it to work

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .