Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wish to play all of the games that I have on Windows 7 by default (chess, freecell, minesweeper, etc) on my Windows 8 machine.

I tried to just copy over the relevant .exe files, but when I run them (even in Windows 7 compatibility mode) nothing happens (no errors, no running process, nothing).

How can I get my games working?

Note: I tried the Into Windows Guide: How To Play Windows 7 Games In Windows 8 and after I downloaded the patch, it still did not work.

share|improve this question
Do you have an nVidia graphics card? – user3463 Jul 29 '12 at 19:23
@RandolphWest Yup. Up to date drivers, 260M – soandos Jul 29 '12 at 19:24
I cannot run any Metro apps with my 560M nVidia, and the behaviour sounds the same. No error, no running process, nothing. I believe there's a known issue with nVidia cards. EDIT I cannot run Windows 7 games on my 8 install either. – user3463 Jul 29 '12 at 19:27
@RandolphWest I have no problems with the built in metro apps, or others that I download. Additionally, these games came from win 7 and so are not metro. – soandos Jul 29 '12 at 19:31
Well I can't exclude nVidia being a problem on my machine, but the 7 games definitely do not start. – user3463 Jul 29 '12 at 19:32

Try to start FreeCell under Dependency Walker.

  1. File -> Open -> FreeCell.exe
  2. Profile -> Start profiling

Of course, you must use appropriate (x32/x64) version of Depends, otherwise you'll get error "Modules with different CPU types were found".

After process FreeCell.exe exits search the log for red lines. May be they give the clue. Incorrect paths for example...

share|improve this answer
Useful program. Copied in a .dll file, but then I a bunch of problems with the win api (API-MS-WIN-CORE-SYNCH-L1-1-0.DLL). – soandos Jul 29 '12 at 20:13
Are you sure, executable was successfully patched? Just tried patch 1.2 on my tablet (Win8 customer preview x86) and it works, running from C:\Program Files\Microsoft Games\FreeCell\FreeCell.exe – Maximus Jul 29 '12 at 20:22
Thats what it said at the end (had to manually find all the .exe files though) – soandos Jul 29 '12 at 20:24
up vote 7 down vote accepted

The problem was that the files were in the wrong folder, and where therefore calling the x86 versions of the api, when they should have been calling the x64 versions.

Just moving them into the Program Files folder (as opposed to the Program Files (x86) folder) fixed the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.