Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my laptop I have a strange bug or something that fairly frequently causes wireless networking to become spontaneously disabled. Network connections drop out & all available APs disappear.

Using the Windows 7 troubleshooter (right-click on networking tray icon -> troubleshoot) detects the issue & correctly fixes it every time, but it takes a few minutes. I know what the resolution is & am wondering if there is a way to (quickly) enable wireless networking in Win7?

Here's a screenshot of the resolution screen that I'm trying to shortcut to.

Turn on wireless capability in Win7

share|improve this question
2  
Just to eliminate the "kick myself" option, lots of laptops come with a button you can push that does an RFKILL, effectively turning off the wifi radio. Is there any possibility you are inadvertently hitting this button? –  Paul Jul 30 '12 at 2:16
    
@Paul my laptop has a hardware switch for that functionality. It is definitely on, as wifi is restored through the OS. Is there a counter signal to RFKILL to enable? –  Mark McDonald Aug 1 '12 at 0:19
    
I do have a software switch for wifi - but it involves pressing Fn-F5, which brings up a Lenovo software dialog with options that need to be moused to & clicked in order to enable / disable wifi. I fear the chance of this happening accidentally is remote, coupled with the fact it happens almost daily. –  Mark McDonald Aug 8 '12 at 5:49

5 Answers 5

This happens because power management turned off wireless capability when not in use. You can change this setting:

  1. Open Network Connections
  2. Right-click on the wireless connection
  3. Click Configure next to the wireless adapter
  4. Click the Power Management tab
  5. Uncheck "Allow the computer to turn off this device to save power"

Like this:

enter image description here

share|improve this answer
1  
Perfect. This was exactly what was happening. My battery is old and the power management started the computer with the wifi disabled. Thanks Sam –  AlexC May 29 '13 at 14:12
    
This should be accepted as answer. This works for me. –  fiberOptics Nov 19 '13 at 11:02

What I think is that you must have accidently pressed the wifi off option from "Windows Mobility center". Try opening it from "Windows Mobility center". You can open "Windows Mobility center" by opening control panel and type "Windows Mobility center".

share|improve this answer
    
I have had this problem, and turning Wifi on from "Windows Mobility Center" fixed it. I hadn't turned it off myself (I would have remembered!), but I think the Lenovo "Access Connections" likes to turn Wifi on/off... or rather, it likes to turn it off, but not back on again. –  psmears Nov 10 '13 at 8:54
    
That's what was the problem on my laptop too. Didn't turn it off, but I guess it's another program that did. –  Jerry Jun 30 at 11:57

My wild guess: Your laptop has a software- controlled button for toggling wifi ( possibly on the keyboard) which you accidentally press, disabling the network adapter. In that case you should be able to turn it on by pressing said button.

share|improve this answer

Sometimes none of above will be useful because the wireless adapter has been disabled from BIOS, in this case you need to enter to the BIOS and set it as default, then login again and go "Windows Mobility Center" through Control Panel and you can turn the wireless adapter ON/OFF.

share|improve this answer

I used FnF2. The F2 on my laptop has a little antenna icon. Must have hit this by mistake once!

This toggles the WiFi on and off.

share|improve this answer

protected by Community Sep 22 '13 at 20:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.