Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay so my problem is that i got internet in browser but terminal has no internet access. Maybe i lack of configuration of terminal. I'm using proxy that is auto configure in company network.

share|improve this question
    
Terminal does not use the internet, it's the command you type in it that does and they have to be configured individually to use the proxy. Most of them don't even support proxies I believe. What exactly are you trying to do? –  billc.cn Jul 30 '12 at 11:24
    
apt-get update dont even work... –  Alex Jul 30 '12 at 13:10
add comment

3 Answers 3

up vote 0 down vote accepted

Open your Ubuntu settings, and go to Network settings. I'm sure there is a global proxy configuration there. Make sure that it points to your host's IP. If it is not, may be you are able to browse Internet as it is explicitly set to use the proxy, that your rest of Ubuntu system may not know.

share|improve this answer
add comment

There is an env var that might help if all else doesnt work.. $http_proxy is used to specify url to proxy. refer to this link

share|improve this answer
add comment

If you go into the network app (superkey then just type network) click on network proxy then select manual and fill in your proxy setting in all the boxes and click apply system wide this will also apply your setting to the terminal. If you have the terminal open at the time you will probably have to close it and open a fresh one.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.