Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Most applications have a hotkey for entering full-screen in OS X with CmdCtrlF, for others I created a keyboard shortcut for Enter Full Screen and Exit Full Screen in system preferences.

But the 3.0 seconds animation is extremely annoying!

How can I disable the OS X animation of windows going into full screen mode?

share|improve this question
    
A similar question at Ask Different: apple.stackexchange.com/questions/17440 –  ؘؘؘؘ May 30 '13 at 3:26
1  
Well i am sorry to say this but as i looked for you there is no way to turn it off the only thing you can do is that tell Apple to fix your problem Here are some urls that might help you apple.com/contact apple.com/support –  idavid Jun 12 '13 at 16:47

3 Answers 3

Navigate to:

chrome://flags/

Scroll down to find the one called "Enable simplified full screen" and disable it. Re-launch Chrome and you are finished.

Source

Disclaimer

Google Chrome - WARNING These experimental features may change, break or disappear at any time.

share|improve this answer
    
It disappeared :( –  Horak Nov 25 at 13:54

I don't think it's possible, but i would reccomend using TotalSpaces as a replacement of Apple's bad implementation. http://totalspaces.binaryage.com

share|improve this answer
1  
Excellent! Solves the problem of switching to other spaces perfectly. But the mission control and full-screen enter are still slow as hell. –  Evgeny Jul 24 '13 at 6:39
    
@Evgeny The Mission Control animations can be disabled with defaults write com.apple.dock expose-animation-duration -float 0; killall Dock. –  ؘؘؘؘ Jul 24 '13 at 7:02
    
@LauriRanta it doesn't help with moving to other spaces. Only for moving in and out of mission control. –  Evgeny Dec 16 '13 at 20:41

If you're using OS X Lion try this:

To disable automatic window animations, open Terminal and type the command:

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO

Found on this site: http://www.chriswrites.com/2012/01/turn-off-animations-eye-candy-effects-in-mac-os-x-lion/

Which has instructions for turning off other animations as well, and a link to 'power toys' like the ones Lorenzo posted in his answer.

share|improve this answer
1  
It doesn't affect the animations for entering and exiting full screen though. –  ؘؘؘؘ Jan 18 '13 at 11:04
    
odd... it seems that it should... not even after a reboot? Dang, I wish my mac wasn't too old for os x... back to google –  krazykat1980 Jan 18 '13 at 21:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.