Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a Windows-7 host machine with Oracle Virtual-Box 4.1.18. I've created a guest OS - Ubuntu 11.10 in Virtual-Box for programming and testing. All things are working fine, however, except one nagging issue. Sometimes when I map my host DVD-ROM drive with the linux guest's DVD-ROM drive, for e.g. when installing software, packages, etc., after doing some work, the host DVD-drive actually disappears from the host! That means, the CD is there, but no longer shows up in my computer. From linux, it won't be accessed from /media/cdrom0. I have to restart the host to make things normal again.

Is this an expected behaviour or a known issue with Windows hosts? Any illumination will be appreciated. Thanks.

share|improve this question
are you running virtualbox with the UI or headless - have you just tried disabling the cd rom drive from the guest,or switched it to use an iso? –  Journeyman Geek Jul 30 '12 at 14:53
@JourneymanGeek - I'm not running virtualbox headless, but with the default GUI. I did not disable the cd-rom drive, but yes, I did switch to ISOs on the host machine. Does that cause an issue? –  Prahlad Yeri Jul 30 '12 at 14:57
nope., but the fact that you're not using the gui means you may need to unmount the drive from cli. Unfortunately i'm stuck using vmware player and windows for school, so will leave this for someone else with more of a clue to answer, but the fact that you're not using the GUI should be in the question. –  Journeyman Geek Jul 30 '12 at 15:00
Sorry, a typo. I'm not running it headless, but with the default GUI. Edited my comment. –  Prahlad Yeri Jul 30 '12 at 15:02
@PrahladYeri Have you figured out how you can make the guest system hide the drive from the host system? I want to achieve this with a Win2000 guest on my Win7 host. –  sjngm Jan 3 '13 at 13:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.