Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed windows seven pro on which I made an admin account, and then my regular account I use for everyday's use.

My issue is that my other partitions contains plenty of data coming from my previous Xp Pro install, and while my admin account can do whatever the hell it wants with it this is not the case with my standard account (UAC pops up everytime I want to edit/move/delete them).

The files/dirs are all owned by an unrecognized GUID (I guess this is my old xp user account).

I tried to use

Z:
TAKEOWN /F * /R

But while it gave me ownership over the files at Z:*, I still don't have "full control" over them granted to me when I have a look at their Effective Permissions.

So then I tried

cacls * /E /G MyAccount:F

But it doesn't seem to work recursively at all.

How can I give myself full control over every single file on drive Z ?

Thanks for any help

PS: I fully understand the risk of that and why user file have specific permissions ect ... The drives I am talking about are to be shared. For exemple, the partition containing my music files is affected.

share|improve this question
    
I would advise against it, at least if there are any applications or system files in that drive. I used takeown to take ownership of every file in C:\ and the system bit back - things stopped working because "System" wasn't the owner of some important files and thus couldn't make modifications to it. Giving the ownership back didn't worked since other files needed normal permissions to work, and then only System could access them. –  Alex Apr 12 '13 at 22:27
add comment

migrated from serverfault.com Sep 23 '09 at 11:34

This question came from our site for professional system and network administrators.

3 Answers

  • Right click root folder
    • properties
    • security
    • advanced
    • owner (tab)
    • edit
    • choose your account from the list (or select from the Other Users or Groups button)
    • select Replace Owner on subcontainers and objects

That will give you ownership on everything

Then follow TheCleaners answer to change permissions.

share|improve this answer
add comment

Log in as the admin account and give the account in question Full Control at the root of Z. Then make sure to reset the inheritable permissions on that drive so that all of the subfolders get those root permissions inherited down.

share|improve this answer
    
It starts doing it then gives error on some files with "access denied" (on regular stuff like Z:folder) :( –  azera Sep 23 '09 at 3:20
add comment

You might want to try commands like this.

Take ownership of everything

TAKEOWN /f "d:\path" /r /d y

Recursively reset permissions to inherit.

ICACLS "d:\path" /reset /T
share|improve this answer
    
doesn't seem to work with a full partition, icacls refuses to start processing the command –  azera Sep 23 '09 at 3:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.