Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my memory from 2GB to 4GB. I followed the instructions of the Motherboard and had four matching 1GB modules. The memory tests OK, is recognised and the system generally seems to work as it should. However, the increased memory makes all my web broswers painfully slow. It takes a few seconds to switch between tabs, it takes about 10 seconds to show any key stroke when completing a form in the browser and scolling down a page takes an age. Something is clearly wrong but I have no idea what! Any ideas? i have checked for malware or a virus but found nothing.

I run Windows 7 on a Asrock AM22NF3 motherboard based system with an Athlon 64 X2 4600+ processor, and NVidia GeForce 6200 graphics card. The only slight issue I can find is that on my devices list I have a PCI Simple Communications Controller which I have never been able to install and so I have it disabled. The system has worked perfectly up to this point and as I say, it is only web browsers that seem to dislike the extra memory. Anyone got anything I can try?

Thanks for taking the time to read my post.

Rob

share|improve this question
2  
Have you tried reverting to the old memory configuration, to confirm that the memory is indeed the problem? –  DaveP Jul 30 '12 at 16:05
1  
If it's related to memory newly installed, this behaviour will happen also with others applications, not only browsers... –  climenole Jul 30 '12 at 18:17

1 Answer 1

If you just bought that memory, and based on what you've shared so far, I'd say return it for a replacement and try again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.