Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to compile a Synergy client so I can use it in a WindRiver Linux environment. I've tried compiling and I keep getting this error:

CMake Error at CMakeLists.txt:195 (message): Missing header: X11/XKBlib.h

However I don't even know if it's even possible to cross-compile Synergy on an ARM platform.

share|improve this question
I compiled Synergy on a Wandboard Quadcore running Ubuntu 12.04. Synergy works like a charm between a Windows computer and the Ubuntu machine, either as a server or as a client. All useful information can be found at – user388436 Nov 10 '14 at 13:01

Synergy should work on ARM (It's in the Raspberry Pi repos.)

It looks like you need the xorg dev header files.

I'm not sure about Wind River Linux but on debian based distros the package name is libx11-dev. Since it's just a header file at worst case you could just grab it from source, drop it somewhere your compiler will pick it up and it should work (although changes are you will probably need a few more).

share|improve this answer

Synergy builds fine on the PI platform with a couple of fixes. For that error you will need to install the libx11-dev package and while installing packages you might as well install libxtst-dev & cmake packages.

Then in an editor open the CMakeLists.txt file and search for X11, you should end up finding the following line: set(CMAKE_INCLUDE_PATH "${CMAKE_INCLUDE_PATH}:/usr/local/include") you will need to change this line to be the following: set(CMAKE_INCLUDE_PATH "${CMAKE_INCLUDE_PATH}:/usr/include").

Now if you run ./configure it should work fine. if you still get the same error you will need to move, copy, delete the cache file CMakeCache.txt.

From there you should be good to go. This was all info i found from this post

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .