Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to bridge my network connection from my OS X host to my Arch Linux guest. However for some reason the bridge network option in VirtualBox doesn't work for any traffic, yet NAT does. How can I fix it?

Current config:

Host:
en0 static IP
static ip: 199.19.84.xx
mask: 255.255.255.0
router: 199.19.84.1

Guest:

en0 DHCP (tried with static)
share|improve this question
    
It sounds like you have a problem in your host OS. What do your interfaces look like there? –  Tanner Jul 30 '12 at 22:38

1 Answer 1

Have you installed all the guest additions for Arch Linux? If yes, then refer the VirtualBox manual page 91 (Bridged Networking):

To enable bridged networking, all you need to do is to open the Settings dialog of a virtual machine, go to the “Network” page and select “Bridged network” in the drop down list for the “Attached to” field.

Have you setup bridged-networking in exact same manner? If yes, then the issue seems somewhere in your host OS. First place to check would be your LAN adapters and firewall settings.

share|improve this answer
    
There is no firewall in the way, and there is virtualbox guest additions installed (and appropriate modules are loaded in the kernel). Could it be that the router will only allocate one IP per machine? (current case with data center). –  Scott Nicol Jul 31 '12 at 18:48
    
Such a restriction is not there on the router, but it could be in your OSX. Did you verify that apart from bridged-network, at least connectivity is there between your guest and the host? OSX must be having a ping or equivalent command to ping your guest. Also, ping from guest to your host. Apart from there, are you sure OSX doesn't use an iptables kind of port restriction (also holds tru for your linux guest)? –  Prahlad Yeri Jul 31 '12 at 19:15
1  
I was using a static IP provided by the data centre, so the router isn't going to just allocate me one. I resolved this by getting another IP and then setting my guest to static and using the new IP. If the router/gateway cannot provide another address, bridged networking in VBox will fail. < SOLUTION! –  Scott Nicol Jul 31 '12 at 20:36
    
Does that mean that you need two virtual NIC cards in the guest - one in the router's range, and another for your static-ip? –  Prahlad Yeri Jul 31 '12 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.