Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am experiencing truncation of text in rich text boxes in preview/PDF mode on a report. There is enough space for the text box to grow on the page, and the text appears in full in layout mode, but is truncated when in preview or rendering a PDF of the report.

It seems that the truncation is not dependent on the length of text being displayed; some long text is not truncated and some short text is truncated. There are no special tags in the rich text data.

The text boxes have Can Grow set to True. In all cases there is plenty of room for the text box to grow into; indeed, adjacent controls grow as expected.

I have discovered that the problem arises when the font for the rich text boxes is Calibri, but does not arise when using Arial I haven't yet had a chance to determine whether the problem is with Calibri only.

This is on 32-bit Access version 14.0.6024.1000 SP1 MSO 14.0.6112.5000. I've been able to replicate it on another machine with the same version of Access, but on yet another machine the problem doesn't arise, and I can preview/print the report with no problems.

I tried re-installing Access and it appeared to briefly fix the problem, but the issue has now reappeared. Feels like a printer driver issue, or possibly something specific to how Access is rendering Calibri in report previews.

share|improve this question
    
Does the solution in this thread apply to your case? –  harrymc Aug 10 '12 at 13:09
    
@harrymc no, my problem is with rich text controls, not date or numeric ones. Thanks though - it's good to get some kind of response! –  sasfrog Aug 13 '12 at 9:53
1  
This is a known bug. 2 years ago MS said they were going to get right on it. Yeah, right. No work around I've found so far. My experience is that it's printer based. I'll post back if I find an answer. –  Tom Collins May 2 '13 at 20:22

2 Answers 2

(Not really an answer - just trying to better analyze the problem.)

You say that re-installing Access has solved the problem for a time.

I would suggest repeating the process :

  1. Re-install Access and reboot.
  2. Verify that the bug is fixed.
  3. If not fixed : Check also what happens when booting in Safe mode.
  4. If fixed : Do Windows Update (including optional updates) and reboot.
  5. If the problem has returned : This is a bad patch by Microsoft. You would need to locate the bad update and hide it.
  6. Otherwise, when the problem returns : Take careful note of any changes or Settings changes that you did just before it returned.
share|improve this answer
    
Thanks, this is a good suggestion. I'll need to find some time to do this between work with clients (which puts it on my long, long list of TODOs...) will report back with details. –  sasfrog Aug 14 '12 at 4:14

Yes, this is a known bug. It's based on the font and printer. Another user claimed that switching to Arial fixed the problem. His issue was with the Calibri font, while mine was with the Tahoma font.

My experience was that it depended on the printer as well, as my client would get this bug with one printer, but not another, using the same computer.

Switching to the Arial font worked for both of us. Except for the testing already mentioned here, there's no list that I can find of which fonts are buggy and which ones work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.