Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My monitor uses 800x600 resolution but accidentally I changed resolution and now am not able to change back to the previous resolution because I can't see well!

How can I change the screen resolution before the pc logs in?

share|improve this question

4 Answers 4

Try booting into Safe Mode by pressing F8 before Windows starts loading. Then you will be able to change resolution and reboot computer alter to see if change took place. Otherwise there is Safe Mode with step-by-step confirmation that you can try.

share|improve this answer

This solution is ugly, but should work:

  • Boot in safe mode (via F8)
  • Remove the driver for the graphical card.
  • Reboot. Win7 will revert to the default driver which only supports 640x480 and 800x600. I think 800x600 is the default for this one)
  • Happily log in and reinstall the driver.

Solutions which I think are much better but which require additional hardware:

  • Connect another monitor which works with the current resolution
  • RDP (if enabled) from another computer, which uses that other computers monitor and resolution.
share|improve this answer

Pressing F8 when booting Windows 7, you can choose to enable low resolution 600x400. It is easier than safe-mode method. When windows has started and if still nothing has happened you can try powering screen off and on again. Worked for me!

share|improve this answer

I had a similar issue. Mine was using an external monitor on a laptop with Windows 7. Switched the external monitor to a high resolution at home, then went to work because of the lower specification monitor it would not display. :-(

As the main screen was set to the external monitor every time I plugged it in the screen resolution window would default to the secondary monitor, which I could not see as it was on the extended desktop elsewhere.

Tried everything, from restarting to F8 safe boot in VGA mode, but to no avail.

In the end I disconnected the monitor and found Intel's Graphics Control Panel (right click on the desktop, Graphics Properties...). Under Options and Support I found hot keys enabled and found that Ctrl + Alt + F3 is Enable Built-in Display. Connected the external monitor, pressed the key combination and presto, my main screen was back to the laptop!

I was then able to set the secondary monitor to the proper resolution.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.