Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have run into a very peculiar Wifi problem. Our Wifi network has several devices that can connect to it just fine; two Macbook Pros, an iMac, and an Android and iOS smartphone. All of them can connect just fine. However, we also have a Windows 7 PC with both an installed wireless card and a USB wireless adapter. And we can't connect to the wireless network with either of them (when I test the USB wireless I disable the onboard wireless first). I can see the networks, and can put in a password, but when I attempt to connect it simply says that it failed. There are two unsecured wireless access points, and of the two I can connect to one, the other gives the same error.

The router doesn't seem like the culprit because most of our other devices can connect just fine. The wireless card itself doesn't seem like the culprit because neither it or the USB wireless adapter can connect. So I'm kind of stumped.

  • The PCIe wireless adapter is a Dell DW1525.
  • The USB wireless adapter is a Netgear WNDA3100v2 N600.
  • The Router is a Linksys WRVS4400N.
share|improve this question
    
To narrow it down you should try: seeing if a different Windows 7 computer can connect to the network that you cannot connect to, trying to connect your Windows 7 computer to a third wireless network somewhere and possibly changing authorization settings on the router. –  user142485 Jul 31 '12 at 13:24
    
@AlexMax: You mentioned that you can't connect to one of the unsecured access points, but does that one definitely work with the other devices? –  James Jul 31 '12 at 13:33

1 Answer 1

It sound like you are using WPA-PSK, this is a known problem in Windows 7 with WPA-PSK. Please have a look at this.

OR Follows these steps (mentioned in URL): -

(A): -

Go into 'Power Options' (Control Panel - Power Options) Whichever plan you have chosen, click "Change plan settings" and the "Change advance power settings". Scroll down, if necessary, to "Wireless Adapter Settings" and click on the + to expand and see "Power Saving Mode". Click the + again to reveal the options for "On battery" and "Plugged in". For both "On battery" and "Plugged in", choose 'Maximum Performance'.

(B): -

Go to Control Panel -> Network and Sharing Center -> Manage wireless networks -> Right-click on the network you are trying to connect to which requires your login credentials -> Properties -> Security -> Advanced settings -> 802.1X settings -> Check 'Specify authentication mode' -> then select user authentication. Click 'ok' until you are back to the 'Manage Wireless Networks'.

Now try to reconnect to the wireless network. Windows should now ask you for login credentials and you should be able to successfully connect.

share|improve this answer
    
Thanks for the in-depth walkthrough. Unfortunately, the power saving trick did not work, and I have no "802.1X settings" tab under Advanced Settings. –  AlexMax Jul 31 '12 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.