Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all, I know that I am trying to do something that is not a good idea ;) However, my situation demands it.

I am trying to set up a network with an AirPort Extreme router for both Wi-Fi and Ethernet devices (1 PC, a few MacBooks, 1 copier, 1 printer), and pipe internet into the router from a Verizon MiFi 5620L Hotspot. I cannot pull Ethernet from the hotspot, only wireless.

I attempted to pick up the wireless on a Mac mini I have, then set up internet sharing, and feed it out the Ethernet port on the mini to the AirPort Extreme router.

I had it all working (all devices connected on the AirPort Extreme network) for awhile, and then it crashed, I can't get it up again and I do not know how to set the IP ranges, etc. correctly on the Mac mini (both wireless and Ethernet connections) and the AirPort Extreme router.

Should they be totally different ranges? Is the Mac mini the router for the AirPort Extreme internet connection?

Any help appreciated. I need a fix today and for a few weeks until I get a hard line to this office.

Thanks!

share|improve this question
    
Different ranges couldn't hurt. I believe the Mac Mini would be the gateway for the Airport Extreme connection. It's a little hard to tell what exactly 'connection sharing' does on OS X... especially if it doesn't 'just work'. Try looking up the route tables on your Mac Mini. Run netstat -nr in terminal. –  Tanner Jul 31 '12 at 15:53
add comment

3 Answers

Yes, the address ranges should all be different. The MiFi will be the router for the Mac mini, the mini should get its upstream address via DHCP via Wi-Fi from the MiFi, the AirPort Extreme should get its upstream address via DHCP via Ethernet from the Mac mini. The AirPort Extreme should be in bridge mode (NAT off), because the Mac mini would already be doing NAT and DHCP for everything downstream of it.

I don't think you can easily adjust the IP address range that a Mac running Internet Sharing gives out, and I think it gives you 192.168.2.x/24 (note the 2) by default, so make sure the MiFi is not using that range.

share|improve this answer
    
So should I be using the APE in which mode? DHCP or bridge? I had it in bridge mode before with the 192.168.2 range –  Amos Arnold Jul 31 '12 at 16:34
    
@AmosArnold Oh, now that you mention it, bridge mode on the AirPort Extreme would be better. I'll update my Answer. –  Spiff Jul 31 '12 at 17:39
add comment

Although somewhat convoluted, I see no reason the setup shouldn't work as you described... if I've understood correctly:

+------------------+
| Wireless Hotspot |
+------------------+
        v
        v
        v
        v
    +--------+     +------+
    |  Mini  |+--->| APE  |
    +--------+     +--+---+
                      |
                      |
   +-------+-------+--v-----+
   |       |       |        |
   +       +       +        +
 +----+  +----+  +----+  +----+
 |    |  |    |  |    |  |    |
 +----+  +----+  +----+  +----+
        Various Things

In the above, the mini is the Router and DHCP server for the APE. The APE is the Router and DHCP server for your various devices. The mini hands out by default (I believe) addresses in the 10.x.x.x space. Check out this question for some insight into how to change that default address pool if you'd like.

The APE will hand out addresses in the pool of your choosing, though I believe the default is also in the 10.x.x.x range.

In order to keep it simple (i.e. keeping as many defaults as possible), I would have the APE set to hand out addresses in the 192.168.x.x range in order to keep the networks distinct.

share|improve this answer
add comment

I dont think its a dumb idea. I too am waiting for a hard line and need a good WiFi Network for use between devices, but my main machine picks up several other WiFi networks. Obviously this is not a permanent solution, but I can attest that bridge mode does in fact work when Internet sharing via ethernet is enabled in system prefs on Mountain Lion and the CAT5 goes from the iMac's <--> to the APE's WAN. The tricky part is that I had to use my iPhone to reconfigure the APE. Now my appleTV can stream from my computer, and the web (slow.)

share|improve this answer
    
What is your solution? How did you do it? Please edit your answer so we can follow what you've done. –  user 99572 is fine Feb 22 '13 at 22:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.