Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My old laptop (LG LW20 Express) got a hdd failure and I replaced the hdd. Now the laptop won't boot from cd or usb. I'm trying to install ubuntu on it.

When I turn the laptop on it shows me the startup screen but when it should be the time to load operating system it just gives a black screen and starts over. This loop continues until I shut down the laptop.

I created the usb boot drive following this guide https://help.ubuntu.com/community/Installation/FromUSBStick/

I used my boot cd to install ubuntu on this machine I'm using right now. So at least the cd should work.

From the BIOS I can see that my newly installed hdd is recognized and put as a secondary master. Also the cd and removable media are in the boot list before hdd.

The laptop runs pretty hot. The fan is at full speed pretty soon after the laptop is turned on. Earlier I suspected that it would have been the almost broken hdd that would have produced that heat but there obviously is something else also.

Any ideas what to check?

share|improve this question
    
I added the location of the heat source into this image mikamustalahti.net/images/heat-source.png. It seems to be either some chips on the mother board or in the SUB. I don't know what that SUB is about. Just read about it from the user manual in tim.id.au/laptops/lg/lw20.pdf –  Mika Jul 31 '12 at 23:58
    
Hmm.. could the SUB be the card reader. At least it locates there. –  Mika Aug 1 '12 at 0:00
    
I think I'm going to try reflowing the motherboard using the guide in here computerrepairtips.net/how-to-reflow-a-laptop-motherboard I have read that it has solved heating issues with some motherboards. Before that I may try to boot using the old hdd because ubuntu on that drive loaded ok despite the disk failure. –  Mika Aug 6 '12 at 12:30
    
I changed the old hdd back in and the laptop started to load ubuntu from the boot cd correctly. The issue is in my new hdd. –  Mika Aug 12 '12 at 7:24
add comment

1 Answer

I had the same problem when I tried to replace the HDD by a 1.8'' SSD, impossible to boot from it (endless reboot loop after BIOS loading). I've managed to update the BIOS by taking a look here and here, and then it worked just fine! I think this is not only relative to the use of SSD, but with the use of a different drive than the original one.

share|improve this answer
1  
Quite possibly a SATA version problem/detection related. Good info on BIOS flashing on your links, it would be more useful to contain the information in your answer incase the source website doesn't work (very slow here). –  HaydnWVN Dec 10 '12 at 11:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.