Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Firefox plugin pentadactyl provides the function of setting a external editor.

default: gvim -f +<line> +"sil! call cursor(0, <column>)" <file>

I installed MacVim on my MacBook,

when I set editor like this, get an error:

set editor='macvim -f +<line> +"sil! call cursor(0, <column>)" <file>'

Command not found: macvim
share|improve this question
up vote 0 down vote accepted

macvim is not an executable in your $PATH but you can use the mvim script bundled with MacVim.

  1. Place the mvim script in your $PATH

  2. Use this setting:

    set editor='mvim -f +<line> +"sil! call cursor(0, <column>)" <file>'
    

You can also use the open command native to Mac OS X like that:

set editor='open -a macvim -f +<line> +"sil! call cursor(0, <column>)" <file>'
share|improve this answer

I had the same problem, and romainl's solution did not work for me.

The kind John-Galt from #pentadactyl at irc.oftc.net helped me.

My mvim executeable was located in ~/.bin/mvim. So I ran

:set editor='~/.bin/mvim -f +<line> +"sil! call cursor(0, <column>)" <file>'

Note that I typed the whole path to the mvim binary. I don't understand why this works, but it did.

This can of course be appended to your .pentadactylrc (without the ':').

share|improve this answer
    
I tried this, but it still throws the error "Command not found: gvim". Any way to edit the part where it assigns gvim as the editor, or other hints on what I'm doing wrong? – Silas Barta Sep 2 '12 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .