Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

EDIT: I solved the problem. It's the last thing I could think about...Windows Firewall !!!

I'm hosting a Windows 2008 Server virtual machine on Ubuntu server 12.04 LTS using virtual box 4.1.18. The windows guest adapter is bridged on ubuntu's eth0 NIC and is pingable from the host (ubuntu server) and other machines on the same network. Also the guest (windows 2008 server) can ping the host and other machines on the network.

But neither the host nor other machines can access a web application hosted on the guest (http, port 80). Using the guest's IE browser, I can access the application so it's functioning already.

I tried setting the promiscuous mode for the guest's NIC:

VBoxManage modifyvm "Win2008Server_x64" --nicpromisc1 allow-all, but that didn't do the trick.

My iptables rules indicate that all traffic is allowed "as Ubuntu should be by default":

root@mysql:~# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

root@mysql:~# iptables -S

About port forwarding, I don't need to do that because I'm bridging the guest's NIC over the host's NIC, correct ?

On a virtual machine, I had tomcat7 running using port 8080. So I changed the webserver's port from 80 to 8080 but that didn't work either so I guess It has nothing to do with ubuntu. It's something about the virtual machine configuration but I can't figure it out !

share|improve this question
Is the host's adapter in promiscuous mode? – Keith Aug 1 '12 at 15:39
The host's ?! I don't know and how would that be a problem ? – Muhammad Gelbana Aug 1 '12 at 15:40
If it's bridging it will need to pass MAC address that is not its own. – Keith Aug 1 '12 at 15:44
Since you solved the problem yourself, post your solution as an answer and accept it. – Renan Aug 1 '12 at 15:44
@Renan, I'll have to wait 5 hours to do that because I have very low reputation credit. – Muhammad Gelbana Aug 1 '12 at 15:49
up vote 0 down vote accepted

It's the last thing I could think about...Windows Firewall !!!

share|improve this answer
Can you elaborate? What about Windows Firewall did you change? – Jeff Oct 3 '12 at 20:20
I added a rule to allow incoming connections to port 80. Or may be a different port for your case. – Muhammad Gelbana Oct 3 '12 at 22:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.