Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm dealing with a strange issue with Windows security. I just switched laptops from one running Win 7 x64 Ultimate, to one running Win 7 x64 professional. I keep all my music on an external drive in a folder called "Music". I use iTunes to listen to it, as my phone, etc, are Apple. In the iTunes settings, I have the library pointed to that folder on the external drive. Everything was copacetic.

So, I install iTunes on the new laptop, and add the same folder on the same drive as the external drive. I realize that when I try and import the library, nothing is happening. I also noticed there was a lock icon on the entire Music folder. I went ahead and right clicked on it and went to security, then made sure that both my user name and the entire Administrators group had full control over the folder and all subfolders and files.

After applying the permissions to the folder, I went back into iTunes and tried my library again. This time it imported with no problems, but now, I can't play any of the music through iTunes. I then went back into the folder and tried to play any of the mp3's individually through vlc, windows media player, etc, etc. Doesn't work. WMP spits out: Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct. So I checked out the permissions on the individual files and they do NOT have my username as having full control. But when I check on the folder that holds them all, I do have full control set with Apply To: "This folder, subfolders, and files"

So what am I doing wrong? The thought of applying individual permissions to every file is enough to make me want to kill myself. Is there some overall way to do this that I am not doing right?

share|improve this question
add comment

2 Answers

On the parent folder containing all files you want to take full control of, do the following:

  1. Right Click on the Folder
  2. Select Properties
  3. Navigate to Security tab
  4. Press the Advanced button
  5. Press the Change Permissions.. button
  6. Give your username full control
  7. Make sure Replace all child object permissions with inheritable permissions from this object is selected
  8. Click Ok, Ok, and then Ok again to acknowledge.

If the username is different between the two systems, you might also need to take ownership of the files first before the permissions will propagate.

share|improve this answer
    
+1 Saved me from an amount of headache. Thanks! –  JW Lim Mar 19 at 4:53
add comment

The way I resolved this problem is as follows:

  1. right click the folder containing the item(s)
  2. select 'Share With'
  3. select 'Specific People'
  4. Type Everyone in the box
  5. click 'Share'

Move to the folder containing your files, click the first file and then press Ctrl-A

  1. right click one of the selected files
  2. select 'Share With'
  3. select 'Specific People'
  4. Type Everyone in the box
  5. click 'Share'

You should be good to go

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.