Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Wi-Fi does not work for a particular network, whose signal strength it shows as full.

What works is:

  1. My machine can connect to all the Wi-Fi networks except that particular one.
  2. All my friends' machines are able to connect to this network.

What I tried is:

  1. Restarting the router, but no effect
  2. Updating my wireless card firmware
  3. Booting into Ubuntu; same issue there as well
  4. Changing my wireless LAN setting to 'Aux' from 'Auto'
  5. Using the Windows 'Troubleshoot problems' utility
  6. Rebooting my machine a hundered times

What could the problem here be? I am posting this right now from a Wi-Fi network, which proves that my Wi-Fi works, just not on that network due to some particular reason.

What should I do to debug this?


Edit: the errors

The error I get is

Windows was unable to connect to ''.

But everything is intermittent. Sometimes it does connect. When it does, it says no internet access.

When it shows internet access, there is a request timeout on each browser request.

This is what ipconfig shows:

Wireless LAN adapter Wireless Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
share|improve this question
1  
What does ipconfig show? Are you getting DHCP? –  Tanner Aug 1 '12 at 22:35
    
What exactly happens when you try to connect? Does it give you an error dialog? (What does it say?) Does it log anything? (What do the logs say?) Does it get connected at the Wi-Fi layer but not get an IP address lease via DHCP? Does it get connected and get an IP address but it can't load web pages from the Internet? What is the make, model, hardware revision, and firmware version of the AP? Of your wireless card? –  Spiff Aug 1 '12 at 23:19
    
@r.tanner.f added the info. Sorry, had a hard time finding a network to use to post this. –  Lazer Aug 3 '12 at 8:11
    
@Spiff: please see my update, thanks. –  Lazer Aug 3 '12 at 8:12
add comment

1 Answer

Check all the settings.

Check that you're connecting with the correct protocols. Whether that be WPA or WPA2 & TKIP or AES CCM.

Check for mis-spellings.

It happened to me just this week. I couldn't get my android phone to route any traffic even though it was saying it was connected. It turns out that I mistyped the password but because of what the password is, I had it typed in a way that made it look like it was correct when it wasn't. And yes, I mistyped it the same way every time. It's probably something as simple as that.

If all that fails, start by setting up from scratch on your computer. First remove the existing entry for the failed wifi connection then try again, entering in all the details slowely. If that fails, try the manual setup approach rather than auto. I've once had an issue where I couldn't get it to operate in the automatic detect settings mode but had to enter manually and lo and behold - it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.