Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old computer I'm repurposing into a NAS (with FreeNAS 8)

I've got a 4-port Sata RAID card, with 4x2TB sata drives, and a 40GB laptop-sized Sata drive (which originally came out of my PS3) (5 drives total)

Obviously I want the 4 large hard drives on the RAID card, so I thought i'd get a SATA to IDE converter for the OS hard drive.

The only thing is, when installing FreeNAS (from an IDE CD drive running on the other mobo IDE port) it will get up to a certain percentage (changes every time, anywhere between 1-20%) and will 'freeze up'. After a couple of seconds, FreeNAS will say successfull installlation, and tells me to restart and remove the CD.

As you might have guessed, FreeNAS in fact did NOT install correctly.

There are a few things that I've run through to try and diagnose any problems

  • Unplugged the other drives from power/raid card, so it is just the OS drive (on the IDE to SATA converter and the CD drive. (No change)
  • Swapped the IDE ports for CD drive/ SATA converter (No change)
  • Burnt and tried another FreeNAS disk (No change)
  • Changed CD drives to another (known working) drive (No change)
  • Ran the OS drive through the RAID card (worked perfectly, and boots fine when connected here, except when moving it back FreeNAS fails to boot due to the different configuration)

Which leaves me with the questions:

  • Is there any other reason that i've missed that might be causing this issue?
  • How reliable are these types of converters? Do I just have a faulty one?
  • Did I blow $30 on a SATA to IDE card when I should've just gotten another RAID card?

EDIT: Added some more info

  • The hard drive is recognised correctly in the BIOS, and by freeNAS when installing (otherwise how could it start installing)
  • The system attempts to boot from the hard drive, and gets so far as to look for the bootloader file, but can't find it and sits there with a boot: prompt
share|improve this question
    
You have not mentioned the most important test: does the BIOS recognize the 49GB HDD with the SATA to IDE converter? Which converter are you using? Does the converter have a BIOS extension that allows its attached drive to be bootable? –  sawdust Aug 2 '12 at 2:10
    
Hi @sawdust - i've added some more info, see edit. unfortunately I'm at work at the moment I can't check the brand/model of the converter. It apparently can work both ways (it has an in and an out sata port, i've checked i'm definitely using the correct one - i've even tried both just in case) –  Robotnik Aug 2 '12 at 3:32
    
Is the SATA drive jumped for the slower 1.5 Gb/sec operation that most converters only support? Have you tried any other HDD operation besides installing FreeNAS and booting? Do you have a HDD diagnostic such as those sold with WD and Seagate (retail) drives? –  sawdust Aug 2 '12 at 5:18
    
@sawdust hmm, that's a good point (the jumper I mean) I've used the hard drive with a caddy for storing/watching movies and as a sort of "portable" hard drive to transfer stuff between computers (with the caddy) so i'm sure it's ok. also, it installs/boots fine when hooked up to the RAID card so I don't think it's a hard drive issue. I'll give the jumper a try when I get home (4 hours to go :/) –  Robotnik Aug 2 '12 at 5:34
    
@sawdust jumped the drive, no such luck - (It's a Seagate 40GB 5400rpm model btw - came out of a PS3). I think I might just bite the bullet and buy a second RAID card they're not that expensive. thanks for your help anyway –  Robotnik Aug 2 '12 at 11:30

1 Answer 1

up vote 0 down vote accepted

bought a second RAID card, and hooked the drive up to that. installs and boots perfectly fine

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.