Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been facing a weird internet problem. I can open sites like google, warez-bb fine without any problems, but when I try to open any blogs, Hotmail, turbobit (I'm not sure what category of sites) I'm simply thrown a server not found error.

Sometimes if I keep on hitting F5(refresh) for 30 seconds or even more than that, pages load fine, sometimes only a text version opens without any images, sometimes they won't open at all. Before writing this in superuser, I had to hit refresh button for the site to open.

I'm totally frustrated with this problem. I've tried firefox, chrome, IE even booted ubuntu and tried opening them. The problem remains same. I don't think this is a virus or some kind of malware because as I said I've already tried browsing in Linux as well. I think it is a problem with my ISP (BSNL India). I've contacted few of my friends with same ISP and they seem to open all sites without any issues.

Any ideas or any pointers to solve this problem would be helpful.

share|improve this question
    
It sounds like your ISP is flaky. –  Mechanical snail Aug 2 '12 at 3:12
    
@ekaj all kinds of blogspot sites refuse to open for the first time –  kunaguvarun Aug 2 '12 at 4:28
    
@Mechanicalsnail, so whom should I contact with? BSNL? I'm guessing my modem would be faulty as I've overused it. Keep it running for more than 10 hrs continuously per day –  kunaguvarun Aug 2 '12 at 4:30
    
Yes, BSNL, especially if it's them you got your modem from. –  Mechanical snail Aug 2 '12 at 5:48

2 Answers 2

I would recommend resetting the BSNL modem(the pin-press reset switch on back panel).
Also, borrow a modem from friend for a day and see it that works fine..
If that is working fine, just export his modem settings and import them in your modem...
Also visit BSNL office and ask them to reset your connection/socket o whatever they call it.

share|improve this answer
    
I thought of the same. But after I met a few ones who had a similar problem, they asked me to change the DNS settings and everything works fine now :) –  kunaguvarun Aug 3 '12 at 14:30
up vote 0 down vote accepted

Change the DNS settings.

Set up Google DNS settings and once done, everything should work fine again.

share|improve this answer
    
don't forget that you can mark your own answers as accepted. thanks! –  ncdownpat Aug 3 '12 at 15:37
    
the google DNS server will be slower as compared to BSNL ones because of our tiny bandwidths in India... –  tumchaaditya Aug 6 '12 at 3:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.