Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to configure a new router (a Linksys WRT160Nv3) with DD-WRT. It seems that no matter what the settings, DNS lookups fail. I can't ping anything outside my network (I get an unknown host message), can't connect in a browser, etc.

I've tried matching the settings in DD-WRT exactly (I think) to the settings for a WRT54GS I have running DD-WRT (which is currently working fine), but to no avail.

I've tried explicitly setting Google's DNS servers ( & as well as the OpenDNS servers.

What can I do to further troubleshoot this problem? I'm not extremely familiar with networking in general and especially diagnostic/command line tools that would be useful in this situation.

share|improve this question
up vote 1 down vote accepted

First thing: try pinging an IP address, such as You said you're getting an unknown host message; that means you pinged a domain name and the DNS lookup failed, but that doesn't tell us anything new.

Does it not work (likely no response)? Well, it seems your new router isn't connecting to the Internet.

One cause of a router silently failing to connect to the ISP that I've encountered is if you forgot to clone the MAC address of the previous device you used to connect to it. See my answer here for more details.

If that isn't the cause, it doesn't seem like there's anything wrong on your end, so you should contact your ISP's support and tell them you can't ping.

share|improve this answer
You were correct - I cloned the MAC address of the other router, and it works great now. THANKS! – tnorthcutt Aug 2 '12 at 3:47
Actually, I take that back - it seemed to work, but then the same problem returned. I'll report back if I can gather any mor info. Does the MAC address eventually revert back to the original from the cloned one? If so, that would explain it working temporarily. – tnorthcutt Aug 2 '12 at 12:08
Now it seems as though I'm able to get an outside connection when my computer is connected to the router with an ethernet cable, but not when connected via wi-fi. Marking this as accepted since it seems to have solved the problem, and I'll probably go ask about the wi-fi issue on apple.SE, since I've had a similar wi-fi problem with another network, and only since upgrading to Mountain Lion. – tnorthcutt Aug 2 '12 at 14:52
Turns out this isn't isolated to connecting with a Mac - my old windows machine also can't get an outside connection via wifi. I'll ask a new question for this. – tnorthcutt Aug 2 '12 at 15:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.