Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu LTS 11.04 and Ubuntu 12.04 on my Dell M5030. My mouse moves choppy and laggy.

I do not encounter this problems on Ubuntu 10.04 on this machine.

I think this bug may com from Unity. But I am not sure how to fix this problem. Could anyone help me solve this problem or suggest ways to fix it?

May be I missed a important thing in my question. In my case, there are no lag memory problems when use. If i use my touch-pad, mouse cursor move normally. It seems to happen with all my usb mouse.

share|improve this question
1  
You might try exploring the Ubuntu exchange. A very similar question to this was asked there. askubuntu.com/questions/133181/… Have you tried that fix? –  Sunny Molini Aug 22 '12 at 20:30
    
Thanks you, Sunny. However, in my case, there are no lag memory problems when use. May be I missed a important thing in my question. If i use my touch-pad, mouse cursor move normally. It seems to happen with all my usb mouse. –  Ironhide Sep 15 '12 at 5:35
add comment

2 Answers

From my experience 90% of such issues is resolved by deactivating various desktop visual effects. Some of them may consume enormous part of your laptop's resources.

Depending on Ubuntu version or desktop settings, try the following actions:

  • Un-check all Compiz effects
  • Disable Unity or switch from Unity 3D to 2D at least

...and you'll probably observe a significant performance's increase. Then you'll be able to activate whatever you really want (and to observe which function causes the problem in your specific case).

share|improve this answer
    
Thanks for your answer. However, in my case, there are no lag memory problems when use. May be I missed a important thing in my question. If i use my touch-pad, mouse cursor move normally. It seems to happen with all my usb mouse. Maybe i need to update my question. –  Ironhide Sep 15 '12 at 5:37
add comment

Go to GRUB screen on boot select linux version, press E to edit and type apci=off after ro quiet. I don't remember how to make it permanent.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.