Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get the following error when I try to run windows update and the windows update service does not appear in the list of services.

Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer.

I have downloaded and run a full scan with malware bytes in safe mode but that hasn't fixed the issue.

I also downloaded the windows update stand-alone installer (Windows6.1-KB947821-v22-x64.msu) and got the following error when I tried to run it:

Installer encountered an error: 0x80070424
The specified service does not exist as an installed service.

I am also missing the wuausrv registry key.

Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services I have the following:
...
WSearchIfxPi
WudfPf
WUDFRd
...
share|improve this question
1  
May be 'sfc /SCANNOW' will help? –  Maximus Aug 2 '12 at 14:00
    
Did you check the services? Is the service installed? Is it running? I believe it is called wuauserv. –  EBGreen Aug 2 '12 at 14:05
    
Show contents of registry key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\wuauserv] –  Maximus Aug 2 '12 at 14:09
    
The service is not installed or running. I ran sfc and it told me I didn't have any integrity errors –  Greg Grinberg Aug 2 '12 at 14:10
    
The wuauserv registry key is missing. I don't see it in regedit. –  Greg Grinberg Aug 2 '12 at 14:19

2 Answers 2

An automatic FixIt for Windows update is available on Microsoft's Knowledge Base: http://support.microsoft.com/kb/971058

Personally I'd scan any such compromised system with the Avira boot CD: http://www.avira.com/en/download/product/avira-antivir-rescue-system

Also consider rebuilding (reinstalling everything). Since you can't really be sure to have removed every problem.

share|improve this answer

Please try to delete (or rename to be safe) c:\windows\softwaredistribution\datastore\logs\edb.log and then reboot and try

share|improve this answer
    
That had no effect. I get the same error after renaming the file and rebooting. –  Greg Grinberg Aug 2 '12 at 15:11
    
Please try the Microsoft malware removal tool from here: microsoft.com/security/pc-security/malware-removal.aspx run the FULL scan. –  Dave Rook Aug 3 '12 at 7:34
    
Strange question, but what graphic card do you use? If ATI, try uninstall the Catalyst, reboot and seeing if this fixes it –  Dave Rook Aug 3 '12 at 7:35
    
Also try the fix for Windows Update by re-isntalling it via this program thewindowsclub.com/downloads/Fix%20WU.zip (I have not tested this) –  Dave Rook Aug 3 '12 at 7:36
    
And lastly, can you do a Windows Restore (and if so , delete the .log file as per my first suggestion after the Restore)? –  Dave Rook Aug 3 '12 at 7:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.