Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Apache2 for a long time. Most of the time I use "virtual hosts", but I just had my provider change me from a "shared-ip" to a "fixed-ip" address.

That's when it all went to hell. All they should have done is change my ip-address.

Here is my configuration:

/etc/httpd/conf has my httpd.conf file. Its last line is

Include conf/vhosts.con

My vhosts file contains:

NameVirtualHost *:80  

<VirtualHost *:80>  
</VirtualHost>

<Directory "/export/home">
  Options Includes ExecCGI Indexes  
  AddHandler cgi-script .pl  
  AllowOverride AuthConfig  
  Order allow,deny  
  Allow from all  
</Directory>

Include conf/webs/website.com
Include conf/webs/web1.com

So each virtual server should be the same with all the permissions – easy, right? And each server is its own file.

web1 is a typical server.. and has access to mysql.

web1.biz:

<VirtualHost *:80>
  ServerName web1.biz
  ServerAlias http://www.web1.biz
  DocumentRoot /export/home/webs/web1/public_html
  ErrorLog /var/log/www/web1/error.log
  TransferLog /var/log/www/web1/transfer.log
</VirtualHost>

Website:

This is my main website with access to mysql myaddmin in /var/www/html/pma so I have a link in my /export/home/webs/website/public_html to /var/www/html/pma. But before they changed my address it worked fine.. with the above configuration.

This is my current configuration but I still get the "Forbidden" error when I try to start phpmyaddmin:

<VirtualHost *:80>
  ServerName website.net
  ServerAlias http://www.website.net
  DocumentRoot /export/home/webs/website/public_html
  DirectoryIndex index.html index.shtml index.pl index.php
  <Directory />
    Options Includes ExecCGI FollowSymLinks
    AllowOverride Indexes
  </Directory>
  ErrorLog /var/log/www/website/error.log
  TransferLog /var/log/www/website/transfer.log
</VirtualHost>
share|improve this question
2  
Welcome to Super User, Cris. Next time you post, please take a minute to check your formatting. Your post was barely readable before. You can see the source code by clicking edit. Thanks! –  slhck Aug 2 '12 at 22:03
    
What exact error message do you see in /var/log/www/website/error.log? –  RedGrittyBrick Aug 2 '12 at 22:06
    
the error.log contains: [Thu Aug 02 20:29:59 2012][error][client 66.169.97.xx] Symbolic link not allowed: /export/home/webs/website/public_html/pma –  Cris H Aug 3 '12 at 2:30

1 Answer 1

This is similar to this question: http://superuser.com/a/819999/355341

Likely, in your case, you were moved to a new server and the configuration changed (your data were moved, but config files no). If the change is from apache 2.2 to 2.4 there is another issue with Required directive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.