Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today I installed Linux Mint Mate in the default configuration and it has an annoying habit of forgetting window sizes and positions after they are closed. Everything gets reopened in the top left corner. I would like it to behave as Windows does, nothing fancy. Is there a solution?

share|improve this question
    
Hi. If you think the below can be accepted as the answer, please do so. Thanks. –  fayadfami Aug 22 at 17:12

2 Answers 2

Lets do a few things and see how it goes. Compiz is the window manager you have in mate desktop. Follow these steps.

  1. Open Menu and search for 'startup programs'. Open it and create a new start up program with these details.

    Name: Compiz
    Command: compiz --replace --fast-filter
    Comment: OpenGL window and compositing manager 
    
  2. Under the startup programs make sure you enable the option that says remember all processes running in next reboot

  3. There is a bug with Linux Mint mate that brings in a second window manager called 'marco' to work along which causes cpu spike. We have to disable it using these instructions.

Install the package 'mateconf-editor' via terminal using this command sudo apt-get install mateconf-editor. After installing type mateconf-editor in terminal. When the editor opens: Go to /desktop/mate/session/required_components/windowmanager and replace "marco" with "compiz".

In the next reboot, if the cpu spike has not come down, we will just move the marco binary which will stop it from starting by default. Just open the terminal again and give this sudo mv -f /usr/bin/marco /usr/bin/marco.bkp

  1. Under menu search for 'Compiz Config Settings Manager' under which you can find all compiz-functions. Make sure you enable 'Window Decoration'. You are free to give all fancy effects there.

Go for a reboot and this should help you.

share|improve this answer
1  
Well I (mate13, 64, 4C, 6G), did as advised above and it worked without a hitch. But, compiz is still heavy on CPU (slightly less without marco loaded), pretty jerky too. And as to remembering windows positions, not very consistent either. Marco seems a much better solution, couldn't retrace my steps fast enough. –  user180481 Dec 15 '12 at 12:31
    
Great. I agree compiz is heavy and inconsistent but preferred than the others. I never got to replace and do a test with marco because it didn't enable out of the way via the options in LMDE 13. –  fayadfami Dec 28 '12 at 6:28

I had the exact same problem. I am running MATE configured to look like Gnome 2.X, and my Window title bars were showing up underneath my upper panel!

Adding to the answer above, once Compiz is installed properly and configured to be your only window manager, go to the "Compiz Config Settings Manager" and make sure that under "Window Management" "Place Windows" is checkmarked and configured. Click "Place Windows". Under the "General" tab, you can change the placement mode. Personally, I find 'Cascade' works very well for me. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.