Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

2Tb Drive, several years old Pentium 4 HP dc7100 machine with v 1.05 of the C786C1 Bios. There is an 80GB SATA drive connected already, which is recognized, the 2TB drive comes up as 0 Mb in the setup utility and prevents any further startup beyond the bios. Got version 2.15 of the bios from HP, Circa 2008, no change in behavior.

This Site mentions that "Big Drive" (48 bit addressing) has generally been supported since 2001, giving access to drives over 137 Gb

Is this a bios problem. Could this hard drive require a more up to date SATA controller? Where do I find what storage addressing is supported by this bios?

share|improve this question

migrated from serverfault.com Aug 3 '12 at 5:39

This question came from our site for professional system and network administrators.

1 Answer 1

If it is a Sata II drive and the motherboard sata ports are Sata I, you'll need to enable/change a jumper setting to run it in legacy mode (1.5Gb/s as opposed to 3Gb/s).

Some hard drives don't actually have a physical jumper (I think newer Western Digital ones don't) so you'll need to look into finding a hard drive firmware version that enables 'legacy mode'

Without knowing the brand of the hard drive I can't offer specific instructions. I've linked the jumper settings for Seagate Drives, it can be a bit hard to find these (In my experience) To find this link I Googled "Legacy Sata mode Seagate Hard Drive jumper settings"

http://knowledge.seagate.com/articles/en_US/FAQ/193991en

I hope this helps!

share|improve this answer
    
I don't think you have to jumper them, most of the time the protocol will configure itself as sata I anyway, the jumper is generally only there when the controller can't handle the configuration request automatically. –  Alex Berry Aug 3 '12 at 11:16
1  
Which might be the case Alex... :) –  HaydnWVN Aug 3 '12 at 11:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.