Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using 3.5.0-rc1-smp+ kernel. And when I close the cover of the laptop on Windows 7 the computer comes into hibernation mode with HDD and fans off. The machine stays cool.

But in Linux the drive is still periodically clicking and the fans are slowly moving. The laptop stays hot.

How can I make it work like in Windows?

share|improve this question
Which distribution are you using? Do you use a desktop environment? If yes, which one? We need a little more information than just the kernel version. – Marco Aug 3 '12 at 9:48
I use Slackware 13.37 with KDE 4.5.5 – user4035 Aug 3 '12 at 11:41

If you use the GNOME desktop environment, you can use gsettings. There are two cases to distinguish and can be set seperately: if the laptop is running on AC or on battery.

gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action hibernate
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action hibernate
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .